Support » Fixing WordPress » Warning: Illegal offset type in… wp-includes/rss.php on line 1459

  • After upgrading to 2.8.3 I now have two lines of identical code at the top of my site:

    Warning: Illegal offset type in /home/.lacydryer/jderosa3/redtablegroup.com/wp-includes/rss.php on line 1459

    How can I resolve these issues?

    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    I have this issue too. 🙁

    Did you find out what it was?

    A lack of response is usually an indication that the advice given was sufficient.

    So to quote what’s already been said.

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    Oh, I have already done that and I have identified the “offending” plugin… but that is only half of the problem as it doesn’t “resolve” the issue…

    Would you mind telling us the name of the “offending” plugin? I’ve been wrestling with intermittent appearances of the same error message for awhile and after doing a lot of research this is the most informative thread I’ve found. I have a few plugins/configs I suspect but would appreciate knowing which one you found to be problematic.

    Thanks in advance.

    Piddleville

    (@piddleville)

    From what I’ve seen with mine, plugins for pulling in RSS feeds seem to generate the error. Honestly, I’m so sick of updates and “deactivating all plugins” to fix the problems I’m not sure I’m going to bother with future updates.

    poimenJohn

    (@poimenjohn)

    It may not be “legal” but I fixed this for the time being by placing a “@” in front of the code on line 1459 of RSS.PHP.

    It was:
    $rss->header[$field] = $val;

    I made it:
    @$rss->header[$field] = $val;

    Now it works fine.

    I know, there is still an error, and a problem, but my blog displays OK and that’s what I needed for now.

    edporteous

    (@edporteous)

    Looks like the offending line has been removed from the trunk and the 2.8 branch.

    The problem is feedwordpress or something similar plugin, i don’t know why appear this error….have you got a fix ?

    It was:
    $rss->header[$field] = $val;

    I made it:
    @$rss->header[$field] = $val;

    Thanks poimenJohn, that fix worked for me. I can confirm the offending plugin on my side is FeedWordpress. I am sure there’ll be a permanent fix soon.

    that doesn’t really solve the problem, it will simply not show that the error is still happening…

    Mark

    (@markschafer)

    I can confirm that feedwordpress is the cause of this problem for blogs on my wpmu installation. I noticed the issue after upgrading buddypress to 1.1+. (wpmu 2.8.4a). I don’t seem to have the problem when disabling buddypress. Are others seeing the problem without using buddypress?

    @edporteous – unfortunately for feedwordpress users the offending line remains in the ‘updated’ rss.php file that is used with this plugin.
    (This is a drop-in replacement for the rss-functions.php provided with the WordPress 1.5 distribution, which upgrades the version of MagpieRSS from 0.51 to 0.8a.)

    I’m getting that same error:

    Warning: Illegal offset type in ../public_html/blog/wp-includes/rss.php
    on line 1459

    I use feedwordpress too but when I disable the plugin I still get a blank page on /blog/wp-includes/rss.php

    I also tried to place an @ (@$rss->header[$field] = $val;) on line 1459, but that didn’t solve anything either.

    Any thoughts?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Warning: Illegal offset type in… wp-includes/rss.php on line 1459’ is closed to new replies.