Support » Alpha/Beta/RC » Warning: Illegal offset type in isset or empty

  • After setting up some custom post types, and enabling them to be viewable in the feed via these instructions, I’m getting this error:

    Warning: Illegal offset type in isset or empty in /home/content/html/wordpress/wp-includes/query.php on line 1715

    What is this a symptom of?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    I think that’s a bug in 3.0 – See

    ah, thanks. hopefully that gets resolved

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Download the latest SVN – should be working now.

    I just received a similar error:

    Warning: Illegal offset type in isset or empty in /home/usrname/public_html/wp-includes/taxonomy.php on line 176

    This is a 3.0 upgrade from 2.8.6. I got it when I tried to export.

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Is that the only error or are you getting headers already sent?


    This error appears to be back in the latest version of WP – 3.0.1 except it now happens in post.php

    History: I have a site that had custom posts working just fine until today. I auto-upgraded to 3.0.1 and now all my posts show up on the pages, posts and any custom-posts admin screens…

    I also get the warning Illegal offset type in isset or empty in wordpress/wp-includes/post.php on line 736 on any of those admin screens

    I don’t believe I am experiencing the ‘headers already sent’ error…

    anyone got around this yet?

    as its a warning can it just be disabled / removed form the UI? everything seems to be working fine now, i just want to tidy it up?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    What plugins are you using? It’s not a problem with naked WordPress, as far as I can tell.


    im using Custom Post Type UI, Admin panel for creating custom post types and custom taxonomies in WordPress.

    I have tried others but this seems to be the best? if not which other one works best for this kind of thing. how come WP doesn have this OOB yet?

    thanks for your response. i just upgraded to 3.0.1 and still got the issue, have kind of managed to hide it in the UI but it still shows

    any help is greatfullly appreciated

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    The plugin is this one:

    IMO it helps to link to the plugin. Anyway, it’s PROBABLY the plugin, so you should go here:

    At the bottom of that page is a new post field. Fill in that and it’ll get posted where the plugin author can find out.

    I’m getting this error after an auto-upgrade to 3.0.1, with plugin Role-Scoper. Location:
    /plugins/role-scoper/lib/agapetry_config_items.php on line 98

    function is_member($name) {
      return isset($this->members[$name]);

    So what happened to members[$name] in 3.0.1?

    I see various mentions of this error, no real solutions. My approach so far:
    1) Need to get control of site: Rename the role-scoper directory to deactivate it.
    2) Disable the site by activating Maintenance Mode plugin.
    3) Leave role-scoper deactivated but check the activation status and update status of all other plugins.
    4) (Later) Diff 3.0 and 3.0.1 to see what happens with members[$name], or wait for someone here with a clue to post some wisdom.

    Crud, and I thought I’d get a better release if I just waited a while to install this…

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Have you posted to the plugin dev for role scooper about this? Asked him/her for help? There may be a fix.



    Hi guys

    I had this same problem using the OP’s link to that code, i’m pretty new to developing in WordPress but I managed to re-work the approach for the same effect by editing the templates where I wanted post types listed.

    If you put the following code before any loop starts they will include any custom post types you want:

                       array('post_type' => array('post', 'yourtype')),


    I’m also having problems with Illegal offset type when I try to active my plugin.

    Warning: Illegal offset type in /home/mysite/dev/my_wp_folder/wp-admin/includes/plugin.php on line 712

    Looking at plugin.php, it’s the validate_plugin() function which throws the error.

    I’ve already got it working on 3 different WP installations on my computer (WP and WPMU) as well as on a hosted webserver. So I’m not sure what’s not valid in my plugin.

    I’ve deactivated all other plugins. I only get this error when I try to ativate my plugin.

    I have just upgraded from WP 2.9 to 3.0.1

    I have just had the same problem.
    This is the message I get:

    Warning: Illegal offset type in isset or empty in /../public_html/wp-includes/post.php on line 736

    Lines 736 and 737 are:

    if ( empty($wp_post_types[$post_type]) )
    		return null;

    I am using WordPress 3.0.5 with PHP Ease Theme.

    I have the following active Plugins:
    Advertising Manager Version 3.4.19
    Akismet Version 2.5.3
    Anti-Captcha Version 20110129
    Change User Version 1.1
    Contact Form 7 Version 2.4.3
    CSV Importer Version 0.3.4
    Custom Single Post Templates Manager Version 1.0
    Datafeedr Random Ads V2 Version 2.0
    List category posts Version 0.18.3
    Manage Your Posts Only Version 0.1
    MapPress Easy Google Maps Version 2.28
    MCE Table Buttons Version 1.0.3
    p2pConverter Version 0.8
    Pretty Link (Lite Version) Version 1.4.55
    Query Multiple Taxonomies Version 1.3.2
    Really Simple CAPTCHA Version 1.2
    Restrict Usernames Version 3.0
    SI CAPTCHA Anti-Spam Version 2.7
    Single Post Template Version 1.3
    Smart Ads Version 2.2
    SocialNews Version 1.1
    TDO Mini Forms Version 0.13.9
    Theme My Login Version 6.0.4
    Top 10 Version 1.6.3
    TSL iframe unfilter Version 1.0
    User Switching Version 0.3.1 Stats Version 1.8.1
    WP Custom Search Version 0.3.16
    WP Hide Dashboard Version 2.0
    WP-reCAPTCHA Version

    It only seems to appear when I am filtering posts, and then I get a blank page saying: Invalid post type.

    Any idea what I can do to fix this.


Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Warning: Illegal offset type in isset or empty’ is closed to new replies.