Warning: gzuncompress() [function.gzuncompress]: data error in /home/alianzap/pu (22 posts)

  1. pedro enrique
    Posted 6 years ago #

    Greetings dear friends I was updating my WordPress 2.8 to 2.9 but I found the following erro to not to be

    Warning: gzuncompress() [function.gzuncompress]: data error in /home/alianzap/public_html/wp-includes/http.php on line 1831

    My site is http://www.alianzapv.com

  2. pnavraj
    Posted 6 years ago #

    Hello Pedro

    I have also face same just before, and i got solution from this link
    Now my site working perfectly.

    Download http.php from below link .Upload to your server and replace old http:php files.


  3. Red1
    Posted 6 years ago #

    I have the same problem with my site.

    Warning: gzuncompress() [function.gzuncompress]: data error in /home/rotherh/public_html/wp-includes/http.php on line 1831

  4. Red1
    Posted 6 years ago #

    Error solved, many thanks.

  5. pedro enrique
    Posted 6 years ago #

    Error solved, many thanks pnavraj
    I still doubt where this error is out programming error in wordpress 2.9

  6. ladypzaz
    Posted 6 years ago #

    Thank you so much, pnavraj!! It worked like a champ!! Had the same error after upgrading to 2.9 last night...

    Warning: gzuncompress() [function.gzuncompress]: data error in /home/ladyp/public_html/wp-includes/http.php on line 1831

    Happy Holidays, Merry Christmas - whatever you celebrate, hope you have a great time!

    Hugs, Patty

  7. How odd... Had to download that file for all my blogs too. A bit strange of an error, everything worked by the log was filled.

  8. craigcac
    Posted 6 years ago #

    Yep, me too. Just upgraded to 2.9 and got the same error.

    Is this a bug in the release?

    I'm using Yoast Breadcrumbs and this error is being flagged in the dashboard under 'Latest News from Yoast'. Anybody else getting this? Only I was wondering if there was any connection.

    Anyway, for now I'll be patching the problem with the http.php file download.

  9. I'm not using that plugin and I got the error on four blogs, one of which has only Akismit for a plugin.

  10. John
    Posted 6 years ago #

    Works like a charm across 5+ sites. Must be a bug in the release, eh?

  11. Looks like a bug.

    From miqrogroove

    The final results are in, and it looks like a last-minute change to the WordPress 2.9 package stepped on a very obscure "feature" of the PHP cURL library. Those goodies are implemented in the packaged file named wp-includes/http.php.

    This patch is waiting for core approval now, but I wanted to put it up here in case anyone needs an alternative to the stop-gap solution from earlier tonight.


    Everyone give a big happy Thank You to fellow blogger and forum member ptmccain who tolerated my intrusions on his server for the better part of the evening to get this figured out.

  12. Try the 2.9.1 beta and help us test it!

  13. FYI, this problem still exists on 2.9.1 Beta1

    I opened http://core.trac.wordpress.org/ticket/11600 to address it. Please add in anything you think I'm missing from that trac.

  14. julieelder
    Posted 6 years ago #

    I am trying to learn everything, but I was wondering if you could explain how you Upload to your server and replace old http:php files. I keep seeing this every where.. Just needing to know the steps to this procedure.. I am using a MAc... Thank you..
    I have this problem in my website also

  15. If you're going to run self-hosted WordPress, or self-hosted anything, you should learn to use FTP. While you can skate by without learning much about Databases, FTP will save your bacon 9 times out of 10.

    There's a Codex page on FTP clients: http://codex.wordpress.org/FTP_Clients - If you're on a Mac, try CyberDuck. It's free and pretty easy :)

    Basically you're going to FTP to your server, navigate to the wp-includes/ folder and upload the file I linked to.

    It's not much harder than copying a file from one folder to another on your computer. Once you log in, it's generally straight forward.

    Alternately, you can upgrade to the 2.9.1 Release Candidate, which fixes this (and other things). See http://wordpress.org/development/2009/12/wordpress-2-9-1-release-candidate-1/

  16. websta
    Posted 6 years ago #

    I thought the fix would be included in 2.9.1? I had uploaded the downloaded http.php file and it repaired it, but upgrading to 2.9.1 breaks it again. Seeing the error appear (twice) in my admin area this time.

    Re-uploading the downloaded http.php file seems to have repaired it, again.

    Here's the download link again: http://core.trac.wordpress.org/export/11450/trunk/wp-includes/http.php

  17. Craig Hesser
    Posted 6 years ago #


    I had the same problem but only on one blog where it is the only one on a host. It appeared only after the automatic upgrade to 2.9 fom 2.8.x.

    After the error shows for the gzuncompress (2x) then I get a list of ALL the database files with comments that they were not written or similar, and it says (the scary part) "MySQL server has gone away" and THAT scared the bejeebers out of me. Except then everything else seemed to function perfectly normally.

    For me, it disappeared after the auto upgrade to 2.9.1 (today).

    Glad to find an easy fix!

    Thanks to all involved.

  18. CraigHesser
    Posted 6 years ago #


    The problem is still there for the older posts, but not for the new ones. That's an interesting twist!

  19. koostamas
    Posted 6 years ago #

    Thnaks. It helped to me, too.
    I went to 2.9.1 ... when I had the error... and with this new file, it has been resolved.

    Thanks for the post!


  20. jeffespo
    Posted 6 years ago #

    I am having the same issue as above, tried the new php, but issue still persists. I am also having an odd dashboard flashing going on where I can only post from IE. Chrome and FF won't let me make updates to posts or add tags to them.

  21. koyder
    Posted 6 years ago #

    Adding the following line to .htaccess solved the problem for me:

    php_flag zlib.output_compression off

Topic Closed

This topic has been closed to new replies.

About this Topic