WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Warning: getimagesize

[Resolved] Warning: getimagesize

Viewing 15 replies - 1 through 15 (of 17 total)
  • I get the same error on my life site.

    I have the same site running on my local, and on a live godaddy server. The plugin works on the my local, but I’m getting the same error on the godaddy server.

    Plugin Author Douglas Karr

    @douglaskarr

    Have you folks all updated? We just pushed an update yesterday.

    Merologin, You are accessing an http request with a windows path. I’m not sure that will work.

    Creeser, Check the user that php runs under. If you’re with godaddy, they use virtual servers so your php user may not actually have access even if you’ve chmod’d it. Find out the user, then chown it to that user and see if it helps.

    Doug, I don’t know what you mean by checking the php of the user. I’m the administrator of both sites. It’s a brand new install, just started this morning on my local and pushed it to godaddy. The server is running PHP version 5.7.12

    @douglas: I guess the error is due to image path. If I suppress that error then it works but the image will be in original size. How can it be resolved?

    Same problem here. Reinstalled no help. Was working but now fails.

    If I remove line 117 from dk-image-rotator-widget.php it works.
    The plugin worked fine until I updatend so I doubt it has anything to do with the server/host.

    I just updated a client’s site (plugins, Headway Theme, WordPress) and the rotator on the home page is broken in the same way as the original poster described. YIKES.

    I

    Hi,

    I am having the same problem as the original poster.

    Warning: getimagesize(/home/opencuny/public_html/files/2013/10/Fine-Muslim-Am-Youth.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/opencuny/public_html/wp-content/plugins/dk-new-medias-image-rotator-widget/dk-image-rotator-widget.php on line 117

    @merologin suggested suppressing the error- how do I do this?

    This seems like a image path error- how do i correct that?

    Any suggestions would be great, thanks!

    Go to dk-image-rotator-widget.php and on line 116 change
    $_SERVER['DOCUMENT_ROOT']
    to
    ABSPATH

    This line will appear like this:
    $image_path = str_replace(get_bloginfo('url'), ABSPATH, $a[0]);

    Plugin Author Douglas Karr

    @douglaskarr

    This is now updated and corrected. The issue was happening do to the path of the images and where WP was installed.

    Im still getting the error even after the update:
    Warning: getimagesize(//wp/wp-content/uploads/2012/11/GenisTop.png) [function.getimagesize]: failed to open stream: No such file or directory in /wp/wp-content/plugins/dk-new-medias-image-rotator-widget/dk-image-rotator-widget.php on line 145

    To fix it, ive removed line 145 and works fine now.
    $sizes = getimagesize($image_path);

    Hi Douglas,

    I just updated wordpress today, and followed that with an update of this plug-in. Get this- I was working in the back end getting all of the images and links into the sidebar widget. After each one, I used the “visit” site link from admin to check to make sure the images were loading and links were working. Everything looked fine – I created 3 with 4 images each.

    Then! I accessed my site directly from google and get the following warning:
    Warning: getimagesize(//wordpress/wp-content/uploads/2014/01/somwpad-e1390453810202.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/content/49/3492049/html/wordpress/wp-content/plugins/dk-new-medias-image-rotator-widget/dk-image-rotator-widget.php on line 145

    This is the same as mircom – but I am not so comfortable removing a line of code.

    Help… please…

    Thanks in advance for your time.

    I probably should not have posted this to a thread that has been marked resolved. Since I did, I will post my latest discovery here and then begin a new thread to make sure you see it.

    What I found today is that if my site is accessed with a www. or http, the images appear without issue and everything works beautifully.

    The error I mention above only happens when I access my site with https. Not sure if there is a way to fix this, or if it needs to be.

    Thanks in advance for your time and patience,

    Lisa

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Warning: getimagesize’ is closed to new replies.