Support » Fixing WordPress » Warning: ftp_fget() expects parameter 1 to be resource, null given in . . .

  • Resolved Steve-CC

    (@steve-cc)


    I am getting this error message on my site and it is affecting how the page is displayed to anonymous visitors:
    Warning: ftp_fget() expects parameter 1 to be resource, null given in /home/public/wp-admin/includes/class-wp-filesystem-ftpext.php on line 143

    I have found other discussions that point to plugins as being the problem and resolved the issue on another site by removing a plugin.
    On this site – I have only 10 plugins installed. They are:
    404page – your smart custom 404 error page, Accessibility by UserWay, All-in-One WP Migration, Code Embed, Disable XML-RPC Pingback, Divi Accessibility, Google XML Sitemaps, Page Specific Menu Items, Smash Balloon Instagram Feed & Wordfence Security

    Here is a link to another thread that I participated in: https://wordpress.org/support/topic/wp-5-3-causes-php-warnings/

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    Have you attempted deactivating your plugins one by one to see if one is causing the issue? Also you may try switching your theme to one of the default WordPress themes.

    Please let me know if this helps!

    [Moderated: Signature removed.]

    • This reply was modified 1 month, 4 weeks ago by t-p.
    Moderator t-p

    (@t-p)

    Side note to @joshben ,

    Please don’t sign your posts, because we can see who you are via your name and avatar. See https://wordpress.org/support/guidelines/#do-not-spam

    I did deactivate my plugins one by one, reloading the site with each one deactivated.
    The problem – error messages at the top of the page even when not logged in – continued to happen.
    Is there some way to simply prevent error messages to show to anonymous visitors? I seem to remember a setting but have not been able to find it.

    In my effort to at least stop the error messages from messing with my public pages one of the code edits caused an error message that pointed at my installed theme – Elegant Themes – Divi.

    Then I added
    define(‘FS_METHOD’, ‘direct’);
    to my wp-config.php file. That seems to be a temporary solution so public pages do not show php error messages.

    I am posting this now since it may be useful to others

    I guess my next stop is in a Divi Theme Forum

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.