Support » Plugin: Schema & Structured Data for WP & AMP » Warning for external Woo products without price

  • Resolved wxia0822

    (@wxia0822hotmailcom)


    After updating the site and adding external Woo products without price, I saw warnings:

    ======================================================================================
    Warning: max(): Array must contain at least one element in /home/wuyi5364/public_html/wp-content/plugins/schema-and-structured-data-for-wp/output/service.php on line 3361
    ……
    Warning: max(): Array must contain at least one element in /home/wuyi5364/public_html/wp-content/plugins/schema-and-structured-data-for-wp/output/service.php on line 3363
    ======================================================================================

    If I input the price for them, the warnings were gone.

    It should be normal if we don’t set price for external products.

    Environment:

    WP: 5.2.4
    Schema & Structured Data for WP: 1.9.15
    Woo: 3.7.1

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Hi there!

    Please update to our latest version 1.9.16. The issue has been resolved in that.

    Let us know.

    wxia0822

    (@wxia0822hotmailcom)

    Thanks – problem is resolved 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Warning for external Woo products without price’ is closed to new replies.