Support » Plugin: flickrRSS » Warning: fopen(/.jpg) [function.fopen]: failed to open stream

  • Resolved Brian

    (@bkurious)


    Today I began seeing the following error message on my website:

    Warning: fopen(/.jpg) [function.fopen]: failed to open stream: Permission denied in /home/.../public_html/wp-content/plugins/flickr-rss/flickrrss.php on line 187

    I’ve removed the widget until I can get it fixed. You can see a screen capture of the warning here.

    I read that Flickr needs a “cache” folder in the root of your domain with permissions set to 777. I’ve done this, but no luck.

    Can anyone help?

    https://wordpress.org/plugins/flickr-rss/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Dave Kellam

    (@eightface)

    Sorry, there’s a bug with the cache in the most recent version I released. If you disable the cache setting on the options page, it should start working again. I also should have a fix pushed through later today.

    Thank you!

    I just upgraded to flickrRSS 5.3.1 and received the header error below:

    Warning: Attempt to modify property of non-object in /home/.../public_html/wp-content/themes/.../functions.php on line 218

    Line 218 of functions.php is used in a code block to “IGNORE PLUGIN UPDATE NOTICES”:

    unset( $value->response['wp-pagenavi/wp-pagenavi.php'] );

    I wouldn’t add anything like that, but it’s possible someone else did. Any idea why flickrRSS (or the code above) isn’t playing nice?

    Plugin Author Dave Kellam

    (@eightface)

    I don’t think it’s related to flickrRSS.

    Seems sort of odd… maybe someone has told wp-pagenavi not to update? Perhaps it’s worth updating the plugin, maybe someone got in through an error and has been suppressing notices about updates to the plugin.

    It is strange. I just deleted the line in functions.php and activated the plugin. It activated fine, but now I’m receiving this error:

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /home/happy/public_html/wp-content/plugins/flickr-rss/flickrrss.php on line 189

    Plugin Author Dave Kellam

    (@eightface)

    Hmm, don’t really know to be honest, was the caching working before. As part of a rewrite, I’ll use built-in WordPress methods for grabbing the files, and not be reliant on system tools.

    Easiest solution for now, is probably to turn the cache off and just load the images from Flickr.

    The caching was working before; I noticed the error when I made my original post. It had working for months before that.

    Unfortunately, caching is a necessity for the site at this point. But, your built-in idea is spot on. Is there a way to stay notified of releases?

    For precaution, for now I’ll just keep the plugin de-activated until an update.

    Thanks for responsiveness. You’ve been helpful!

    Plugin Author Dave Kellam

    (@eightface)

    If you still need caching, and an old version of the plugin worked, you can still grab them here: http://wordpress.org/plugins/flickr-rss/developers/. Nothing really changed other than fetching the images from an https:// url. It’s possible that your server has some sort of issue grabbing from an https url.

    Thanks, that worked. I downloaded and installed 4.0. I tried using flickr-rss’s cache in conjunction with WP Super Cache, but it didn’t work. So I deactivated the flickr-rss cache feature and it still works perfectly.

    Cheers!

    I’ve got 5.3.1 and the same issues:

    Warning: fopen(/15165753316_ab650e4f75_s.jpg) [function.fopen]: failed to open stream: Permission denied in /home/(path)/wordpress/wp-content/plugins/flickr-rss/flickrrss.php on line 187
    
    Warning: fwrite() expects parameter 1 to be resource, boolean given in /home/(path)/wordpress/wp-content/plugins/flickr-rss/flickrrss.php on line 189
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/(path)/wordpress/wp-content/plugins/flickr-rss/flickrrss.php on line 190

    Caching is turned off, and I’m reluctant to downgrade the plugin – I just upgraded to WP 4, so I’m turning your plugin off for now. If you come up with a fix, or need someone to test, please let me know.

    Yeh, similar problem here: http://restorechurchboston.co.uk/gallery/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Warning: fopen(/.jpg) [function.fopen]: failed to open stream’ is closed to new replies.