WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Warning: failed to open stream. No such file or directory

[Resolved] Warning: failed to open stream. No such file or directory

  • Warning: require(/home/kelseyh/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home/kelseyh/public_html/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/home/kelseyh/public_html/wp-includes/load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/kelseyh/public_html/wp-settings.php on line 21

    Any idea what this means/how to fix?!

Viewing 11 replies - 1 through 11 (of 11 total)
  • What were you doing right before you got this error?

    1. Were you editing any core WP files?

    2. Did you just activate a plugin or a theme?

    I was receiving this error before: Warning: Cannot modify header information – headers already sent by (output started at /home/kelseyh/public_html/wp-content/themes/classica/admin/admin-functions.php:96) in /home/kelseyh/public_html/wp-includes/pluggable.php on line 876

    In an effort to solve this problem I re-installed the admin-functions file via FTP. Then received the latest error posted earlier

    Hmmm…

    The first warning message was generated by your theme. Something in the code was attempting to re-send data to the header.

    You shouldn’t have had to replace WP core code. Simply switching out of your “Classica” theme would have solved the problem.

    Now… the new fatal error message is a WP conflict. Are you certain you replaced with the correct “admin-functions” file?? I bet you used the one from your theme. TSK TSK!!

    You need to download a fresh copy of WordPress… make sure it’s the correct version you had… and get the “admin-functions.php” file from there. FTP it to your site, and you should be good to go.

    I did upload the one from my theme…
    Sorry for being a complete newbie with all of this and asking a zillion questions, but in terms of downloading a new copy of wordpres- should I do so through my host service? Do I need to uninstall the previous version first?

    Okay…

    Let’s first make sure we understand each other. Where did you upload the “admin-functions.php” file to… on your server? Which directory?

    I uploaded the file to my public_html/wp-admin directory

    Yep.. that’s your problem.

    Okay.. download a fresh copy of WP from HERE.

    Then, extract the files to your desktop.

    Now, open your FTP and from your newly extracted folder.. replace the “wp-admin/admin-functions.php” file and overwrite it on your server at the “public_html/wp-admin/admin-functions.php” location.

    Managed to figure it out! Thankfull had WordPress backed up prior to the update to 3.5.1. Thanks for your help though! Really appreciate it!

    My pleasure.

    Glad you got it worked out!

    Hi Josh,
    I’m hoping you could help me with a similar issue? I am completely clueless about computer software so I am really struggling with trying to find a solution on the forums…. the terminology does not make any sense to me!

    I have received the below error message when I try to upload images:
    “Warning: getimagesize(website.com\blog/wp-content/uploads/wpsc/product_images/***.jpg) [function.getimagesize]: failed to open stream: No such file or directory in website.com\wp-content\plugins\wp-e-commerce\wpsc-admin\includes\display-items-functions.php on line 1125”

    If you know how to fix this please would you give me an “idiots’ guide”… without any technical terminology?! Sorry to be such a pain!

    I should also tell you that I am running a very old version of wordpress (3.0.1) but I am terrified to update it because I haven’t backed anything up and am not sure what to do…

    Thanks so much
    Ann

    WPyogi

    @wpyogi

    Forum Moderator

    @poppiescottage – this thread is already marked resolved – and it’s not your thread – please stick with the one you have here –

    http://wordpress.org/support/topic/problems-uploading-images-14?replies=4

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Warning: failed to open stream. No such file or directory’ is closed to new replies.