WordPress.org

Forums

Real Estate Website Builder
[resolved] Warning: exec() has been disabled for security reasons in /var/zpanel/hostdata/c (10 posts)

  1. caleb12134
    Member
    Posted 2 years ago #

    The plugin here "http://wordpress.org/plugins/placester/" won't work? I get this error.
    Please help ? I really need this plugin? Thanks!

    Plugin could not be activated because it triggered a fatal error.
    ---------------------------------------------------------
    Warning: exec() has been disabled for security reasons in /var/zpanel/hostdata/christina/public_html/omegarealtorsgroup_tk/wp-content/plugins/placester/third-party/mixpanel/mixpanel.php on line 28

    http://wordpress.org/extend/plugins/placester/

  2. Placester Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Caleb,

    Looks like exec() has been disabled in your hosts version of php. This can happen when you're on a shared hosting provider.

    We'll update the plugin so it gracefully handles the case when exec isn't enabled. In the mean time, this warning should only appear once on activation.

    Let us know if you're continuing to see it and we'll help you work through the issues.

  3. caleb12134
    Member
    Posted 2 years ago #

    Hey thanks, I looked in /etc/php5/apache2/php.ini and SafeMode is disabled. I run the server on linux. I actually own the Dell PowerEdge, I would appreciate any help :)

  4. Placester Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Caleb,

    Are you still unable to activate the plugin? Depending on which version of PHP you have, it is possible that safe mode could still trip you up.

    Have you checked if you have safe mode enabled somewhere else and have a restriction on the WordPress folder perhaps using something like safe_mode_exec_dir with safe mode on? Or perhaps have disabled exec in the PHP setting disable_functions?

    You could take a look at the settings that are actually in use in your WordPress installation by using the phpinfo() command in a php file in the WordPress folder and calling the file directly from your browser.
    Example file called test.php to generate a page displaying PHP/server configuration:

    <?php
    phpinfo();

    It will generate a page of information including the state of any safe mode related settings. Obviously this is not something to leave on a public website so please delete the file when done.

  5. caleb12134
    Member
    Posted 2 years ago #

    Here is the list. Also are you going to make the plugin without the exec() function? I appreciate it!
    System Linux ubuntu 3.5.0-34-generic #55~precise1-Ubuntu SMP Fri Jun 7 16:25:50 UTC 2013 x86_64
    Build Date Mar 11 2013 14:15:21
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php5/apache2
    Loaded Configuration File /etc/php5/apache2/php.ini
    Scan this dir for additional .ini files /etc/php5/apache2/conf.d
    Additional .ini files parsed /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/imap.ini, /etc/php5/apache2/conf.d/mcrypt.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/suhosin.ini, /etc/php5/apache2/conf.d/xmlrpc.ini, /etc/php5/apache2/conf.d/xsl.ini
    PHP API 20090626
    PHP Extension 20090626
    Zend Extension 220090626
    Zend Extension Build API220090626,NTS
    PHP Extension Build API20090626,NTS
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    Zend Multibyte Support disabled
    IPv6 Support enabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*

  6. Placester Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Caleb,

    It looks like it is using the php.ini file you mentioned, so safe mode should be disabled.

    However, to double check if it really is disabled, look a little further down the output on that screen and you will see a section called 'Core'. In there you will see the following settings:
    PHP Version
    and:
    safe_mode
    safe_mode_exec_dir
    safe_mode_include_dir

    No need to paste the whole section, but take a look at those settings to see if they are set, and if so to what values.

    In answer to your question about removing the exec command, that is something we are working on for an upcoming release.

  7. caleb12134
    Member
    Posted 2 years ago #

    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir no value no value

    this is what i saw? I am running this on a hosting account so it runs through zpanel on my server? So could it be a setting on the account?

  8. Placester Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Caleb,

    You had said that you owned the box - is it a dedicated host maintained by a hosting service? If so then I would contact them and ask if they have somehow disabled exec().

  9. caleb12134
    Member
    Posted 2 years ago #

    It is in my house on the 1st floor. If you wanted I could possibly setup vnc or ssh and give you temp access. How soon until I should expect the new plugin update without exec()? thanks!

  10. Placester Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Caleb,

    Probably the faster way to get you up and running is for you to disable the exec call in the code. It's pretty straightforward - open the file third-party/mixpanel/mixpanel.php in the Placester plugin and look for

    function track($event, $properties=array()) {
            $params = array(

    and change it to:

    function track($event, $properties=array()) {
            return;
            $params = array(

    You can do this either using a text editor and going to the file in:
    <path to your WordPress installation>/wp-content/plugins/placester/third-party/mixpanel/mixpanel.php

    Or, (depending on how restrictive you have set the file permissions on your WordPress installation) you can do it from within WordPress itself by going to the admin menu Plugins->Editor, then select 'Real Estate Website Builder' from the drop down labelled 'Select plugin to edit' and clicking the 'Select' button. Below the drop down a list of all the plugin's files will appear. Select placester/third-party/mixpanel/mixpanel.php, make the change and save.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Real Estate Website Builder
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic