WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Warning Error after upgrading this plugin

[Resolved] Warning Error after upgrading this plugin

  • I get the following error because I upgraded to the latest WP version and the latest version of this plugin:

    Warning: Cannot modify header information – headers already sent by (output started at /canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /canigivemycat.com/wp-login.php on line….

    There are several indicated lines of errors all of them start with Warning: Cannot modify header information – headers already sent by…

    Any idea how I can fix this? Thanks

    https://wordpress.org/plugins/device-theme-switcher/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author James Mehorter

    @jamesmehorter

    Please provide the complete list of warnings/errors and any other info that will help me identically mirror your issue in my local setup.

    Sure. I get the following when I go to my WP panel to login:

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-login.php on line 414

    Warning: Cannot modify header information – headers already sent by (output started at /canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-login.php on line 426

    After logging in I get a white screen with the following, no dashboard:

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-login.php on line 414

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-login.php on line 426

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-includes/pluggable.php on line 861

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-includes/pluggable.php on line 862

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-includes/pluggable.php on line 863

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/canigivemycat.com/wp-content/plugins/device-theme-switcher/inc/class.switcher.php:1) in /public_html/canigivemycat.com/wp-includes/pluggable.php on line 1121

    I can no longer replicate what it shows when logging out because I can’t login any more. The site seems to show normally on the front end.

    Plugin Author James Mehorter

    @jamesmehorter

    Hey @anefarious1 I’ve just released DTS 2.8 which should correct these issues for you. Please update asap and if you don’t mind, please confirm that the update fixes the issues you noted. Thanks!

    It appears the problem is 100% fixed. Marking resolved. You are a wizard. Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Warning Error after upgrading this plugin’ is closed to new replies.