Support » Plugin: Slimstat Analytics » WARNING! DO NOT UPDATE! TO 4.4.2

  • Resolved questionabout

    (@questionabout)


    THIS UPDATE WILL BREAK YOUR SITE!
    Fatal error: Unsupported operand types in /home/****/public_html/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 77829

Viewing 15 replies - 16 through 30 (of 39 total)
  • Hi

    Instead of move it away I tested to delete browscap totally went back to Slimstat which was now working with latest version and activated browscap from settings. Now the folder is back and now its working again as it should. So then I assume the issue is around the package of latest update that cause some issue for this library as its back where it should be.

    @psn solution is working.
    Delete via ftp or cpanel the file browscap-db.php in wp-content/plugin/wp-slimstat/browscap/browscap-db.php
    Reload page.
    File will be downloaded again and all working

    I also tryed to deactivate and reactivate the plugin after this step, and no problem

    It’s seem working now, i have updated 5 wp site with success.
    No 500 error now

    Plugin Author Jason Crouse

    (@coolmann)

    I’m glad to see that everything is working fine now. Please DO NOT DELETE the entire browscap folder, as some of the files in that folder are needed by Slimstat in order to do its job. You can just delete browscap-db.php, if it is still causing problems. As someone said, this is an “optional” library, used to increase the accuracy of converting a User Agent string into a browser name and operating system. Slimstat uses two methods to do that: one heuristic function, that tries to analyze the string for well known patterns, and the data file. The heuristic function WILL NOT be able to cover all the most obscure User Agent strings available out there, and might return false positives for search engines. Browscap, on the other hand, is a comprehensive collection of User Agent strings, and is a very reliable data source. Although it requires more memory compared to the heuristic approach. By default, Slimstat is configured to use the heuristic function, and only if browscap-db.php is downloaded and installed, to use that instead.

    Hope this helps,
    Jason

    The solution didn’t work, because the file browscap-db.php did not excist. Only browser.php and uadetector.php are in that directory. I had to delete the slimstat directory to make the site up and running, it’s no option to wait longer for a solution. Please stop this update, 1000’s websites are broken.

    Looking to the content of the browscap map I found that, compared with the former version, the programm browscap-db.php was missing.
    The problem was solved by replacing the 4.4.2 brouwscap map by the former edition of this map.

    Whilst the update hasn’t broken any of my sites (I updated about an hour ago, and all running PHP Version 5.6.25), I have found that after switching from heuristic to new browscap option, the icons don’t display properly for browser or operating system (and operating system doesn’t display at all).

    Any idea why?

    I thought the new option was meant to be more accurate. At present it is failing to register information

    Plugin Author Jason Crouse

    (@coolmann)

    Let me clarify a couple of points here. To those who are pointing out that browscap-db.php DOES NOT EXIST in the folder right after the update, please note that that’s the EXPECTED BEHAVIOR. This third party data file will be downloaded from the repository as soon as you click on the corresponding button in the Maintenance screen. If that file does NOT exist, Slimstat will be using the built-in heuristic function to identify your visitors’ browser names and operating systems from their User Agent string.

    @robf, could you contact me via http://support.wp-slimstat.com so that we can troubleshoot that issue directly where it is happening?

    Thanks,
    Jason

    Thanks, Jason, just raised ticket. It is happening on multiple sites

    I can confirm the same problem, I have my plugins set to update automatically through jetpack, and I started getting notifications that my site went down. Looking through the logs I see that slimstat is causing a 500 error. Here is a section of the error log where the error started occurring:

    [Thu Sep 29 01:29:30.262676 2016] [fcgid:warn] [pid 3175] [client 37.187.213.135:40845] mod_fcgid: stderr: PHP Parse error: syntax error, unexpected ''a:2:{i:3;i:64574;i:10;s:5:"Wi' (T_ENCAPSED_AND_WHITESPACE), expecting ')' in /var/www/vhosts/cappellaniauniroma3.org/httpdocs/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 34863, referer: http://www.cappellaniauniroma3.org/wp-cron.php?doing_wp_cron=1475105367.1424028873443603515625 
    [Thu Sep 29 01:29:31.192033 2016] [fcgid:warn] [pid 31629] [client 78.46.82.170:40843] mod_fcgid: stderr: PHP Fatal error: Unsupported operand types in /var/www/vhosts/cappellaniauniroma3.org/httpdocs/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 77829 
    [Thu Sep 29 01:30:20.397604 2016] [fcgid:warn] [pid 31629] [client 185.129.62.63:40860] mod_fcgid: stderr: PHP Fatal error: Unsupported operand types in /var/www/vhosts/cappellaniauniroma3.org/httpdocs/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 77829 
    [Thu Sep 29 01:32:17.432960 2016] [fcgid:warn] [pid 31629] [client 192.0.101.226:40862] mod_fcgid: stderr: PHP Fatal error: Unsupported operand types in /var/www/vhosts/cappellaniauniroma3.org/httpdocs/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 77829 
    [Thu Sep 29 01:32:19.923301 2016] [fcgid:warn] [pid 29615] [client 37.187.213.135:40864] mod_fcgid: stderr: PHP Fatal error: Unsupported operand types in /var/www/vhosts/cappellaniauniroma3.org/httpdocs/wp-content/plugins/wp-slimstat/browscap/browscap-db.php on line 77829, referer: http://www.cappellaniauniroma3.org/wp-cron.php?doing_wp_cron=1475105536.1161010265350341796875 

    Now I have to disable slimstat manually to get my site up and running again…

    P.S. following the suggestions from this thread, I renamed browscap-db.php to browscap-db.php.bak and my site is now running again. I also see that the browscap-db.php has been automatically downloaded again.

    • This reply was modified 1 year, 1 month ago by  John D'Orazio. Reason: posted fix
    Plugin Author Jason Crouse

    (@coolmann)

    John,

    if you want to test the fix, you can simply edit the plugin’s headers ( Plugins > Editor > Slimstat from the dropdown > Edit ) and change the version number back to 4.4.1 and then save. This will force WP to re-download the package. Please let me know if this solves the problem for you.

    Jason

    Just for info, if anyone else is getting issue with data not being displayed properly using browscap db I can confirm that setting back to heuristic solves the problem, so definitely looks like a bug.

    Look forward to response via my support ticket tomorrow as time zones got in the way (uk here)!

    Installing browscap, can’t view browser name and operating system. Only “Question Mark”.
    For more info: https://postimg.org/image/bd8c47skd/

    Yes, same problem as I am getting here on 17 different sites. Uninstalling browscap gets around it. Hoping support can resolve the issue.

    I have the same problem as @elinek: I initially removed the plugin to get my sites up. I can move it back to the plugin directory – but as soon as I activate it: Site is down. There is no db file to delete, only the to 2 before mentioned files.
    This is a multisite install running behind a nginx proxy.

Viewing 15 replies - 16 through 30 (of 39 total)
  • The topic ‘WARNING! DO NOT UPDATE! TO 4.4.2’ is closed to new replies.