Support » Plugin: Mi Tienda MercadoLibre » Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be

  • Resolved hernanlo86

    (@hernanlo86)


    Hi all,
    i have installed it, activated and i got this error:
    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/a2315234/public_html/wp-content/plugins/mercadolibre-integration/mercadolibre-integration.php on line 209

    any ideas what i could be?

    i have searched for answers but what i found is that it could be a hosting problem, but now im stuck.

    any advise will be appreciated.

    REgards.

    http://wordpress.org/plugins/mi-tienda-mercadolibre/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author hmgauna

    (@hmgauna)

    Hi!

    Please try deleting or commenting this line of code (line 68):

    curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);

    I will publish some fixes in the future, anyways. Let me know if it works.

    Regards,
    Hernán

    Hi Hernán! that Worked =)
    one more thing…i can only see 1 item from my ML user…i have already set the productos_por_pagina=’6′ and i have a couple of items published in ML, any advise?

    thanks a lot!

    Plugin Author hmgauna

    (@hmgauna)

    Would you post here the website URL and / or your ML username?

    hi her,

    site: http://www.dequemanera.com, ML user=dqmanera

    thanks for taking a look

    Plugin Author hmgauna

    (@hmgauna)

    Take a look, your other products are probably on hold (not active). If you take a look here, you will see that there is only one product listed for your user:

    http://listado.mercadolibre.com.ar/_CustId_33392158

    Best regards!

    her, the wier thing is that i have 2 items published and in the list u sent me i only see 1…
    check this out
    http://articulo.mercadolibre.com.ar/MLA-474427467-apple-iphone-blanco-y-negro-16gb-personal-movistar-claro-_JM

    any advise?

    thanks

    Plugin Author hmgauna

    (@hmgauna)

    Unluckily, this seems to be a limitation on the ML policies.

    They are not showing your ‘free’ listing in the results (neither of them, which of course includes the API I am using), because it’s free. I have tried to hack it somehow, but did not find anything useful yet. The fact that they don’t even show that in their own page is discouraging.

    However, the API will return information from a given product if you use the specific ID. Not very useful, but a solution for those cases could be add a feature to specify those missing IDs. Maybe an optional parameter to the shortcode like [include_free=ID]. Not as good as the original solution, though.

    What do you think?

    it did worked! thanks a lot and sry for taking so long!!

    have a good one.

    Plugin Author hmgauna

    (@hmgauna)

    Great, I am closing the topic. I will publish this fix anyways soon.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be’ is closed to new replies.