Support » Plugin: Collapsing Categories » Warning: count()… collapscatlist.php on line 508

  • urka

    (@urka)


    Hi, I am testing the plugin on my stage page that’s why I can not post a link. On the top on each widget I insert I get under the Title the Warning message:

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/.sites/74/site3501189/web/stage99/wp-content/plugins/collapsing-categories/collapscatlist.php on line 508
    In Advanced options it does not change anything if I activate “Show debugging information (shows up as a hidden pre right after the title) or not.

    I have no idea what happens because all other works fine as I add and change in the setting.

Viewing 1 replies (of 1 total)
  • Hi,

    I solved that error by me, changing count($posts) to count((array)$posts)

    in the program file specified in the error.

    by me in the folder /plugins/collapsing-categories/collapscatlist.php.(line 134)

    might be there are other count() sentences in the code have to be changed.

    Hope that helps, by me it works.

    think you have to change count() too in file /home/.sites/74/site3501189/web/stage99/wp-content/plugins/collapsing-categories/collapscatlist.php on line 508

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.