• Resolved villoz

    (@villoz)


    Warning: Constant WPSC_VERSION already defined in /home/clients/006d8efd2028025091d85c30dac2a813/web/wp-content/plugins/wp-super-cache/wp-cache.php on line 32

    How can we remove this warning?

    We use WP Super Cache 1.9.4

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Can you track down where you saw this warning? Was it when you installed the plugin? That constant is defined in wp-cache.php which is loaded by WordPress once, so it shouldn’t be loaded twice. In fact you should have many fatal errors about functions in that file if you’re seeing this warning.

    Did someone define “WPSC_VERSION” elsewhere on your server, perhaps for testing purposes?

    Thread Starter villoz

    (@villoz)

    The error message appears on each page of the website.

    We don’t use WPSC_VERSION

    How can we totally delete WP Super Cache and what folder of wp super cache should we delte on the website and reinstall it to see if the problem occurs again?

    Go to the Plugins page and look for WP Super Cache, you can deactivate it and delete it from there.

    Thread Starter villoz

    (@villoz)

    Extension removed and reinstalled. Same problem.

    Warning: Constant WPSC_VERSION already defined in /home/clients/006d8efd2028025091d85c30dac2a813/web/wp-content/plugins/wp-super-cache/wp-cache.php on line 32

    I’m at a loss to what’s causing this. There’s no reason for wp-cache.php to be loaded twice, which would cause this warning, and in fact, you would get more serious fatal errors because functions are being loaded twice too.

    Maybe your hosting support can help track it down. A Google search shows that 2 other sites have had this problem too, but I’m sorry. I can’t see why it would happen.

    If you can, search for the string WPSC_VERSION in your blog files. Maybe some automated system copied that or a portion of wp-cache.php elsewhere and that’s why it’s already defined.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Warning: Constant WPSC_VERSION already defined’ is closed to new replies.