WordPress.org

Support

Support » Plugins and Hacks » Flat Rate per State/Country/Region for WooCommerce » [Resolved] Warning : conflict with WC 2.1

[Resolved] Warning : conflict with WC 2.1

Viewing 7 replies - 1 through 7 (of 7 total)
  • The same here! How to fix it?

    Same here, any solutions?

    We’re working on a fix.

    Sorry for the delay.

    contremaitre: We do not find anything on the code that could indicate that the plugin is saving prices to the DB with commas instead of decimals.

    We do not think this is the problem. Can you please give us more information?

    The bug I encountered is described here (only since WC 2.1) :
    https://github.com/woothemes/woocommerce/issues/4778
    As soon as I disabled this plugin plugin, all was fine again.

    I’ve looked at that link and it does not explain why this problem happens with our plugin.

    There are no “taxes” on this plugin. This plugin sets flat (monetary and not percentage) rates. The values are always stored using “.” as decimal, no matter what the WooCommerce settings. We use php’s “float” function to make sure the calculations are made correctly.

    The problem we do know we have since 2.1 is the value not loading on the checkout page when you change the billing country.

    We are investigating on this and if you still think this is a “,” vs. “.” issue, please reply with more detailed information.

    We made some extra checks and changed the configuration fields in order to make sure the values are displayed WITH localization and stored WITHOUT localization.

    It should be fixed on 1.1

    Please give us feedback.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Warning : conflict with WC 2.1’ is closed to new replies.
Skip to toolbar