Support » Fixing WordPress » Warning: chmod(): Operation not permitted after WordPress 5.3 update

  • Hi there,

    I started having Warnings such as these, after updating to WordPress 5.3. Does anyone know why, and how to get rid of them / fix the problem if needed ?

    * Warning: touch(): Utime failed: Operation not permitted in wp-admin/includes/class-wp-filesystem-direct.php on line 479
    * Warning: chmod(): Operation not permitted in wp-admin/includes/class-wp-filesystem-direct.php on line 168

    Thanks !
    Jonathan

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Marius L. J.

    (@clorith)

    Hiya,

    So this might be one of two things, it’s possible that it’s a file permissions issue (if you visit the Tools > Site Health, it will hopefully give some more information on that), or just something like a bad file cache that’s gotten stuck after the update.

    I would start checking Site Health first though, and let us know what that tells you.

    Hi there,

    Thanks for your reply! Unfortunately, when I check Site Health, everything is marked as writeable under file permissions, and I can’t see any warnings in Site Health generally speaking.

    Any other suggestions would be helpful!

    Thanks,
    Jonathan

    Same here.

    Site Health looks fine.

    Hosting in a Cloudways server (Digital Ocean).

    Thanks

    Moderator Marius L. J.

    (@clorith)

    Do you have any kind of caching running, I’ve seen similar behaviors when a static file cache, or an object cache, have gone stale (flushing the caches, or restarting the service using them, like apache/nginx/php-fpm have often helped in such cases)

    John, I’m on a Cloudways server (Digital Ocean too)! Maybe it’s not just a coincidence ?

    Marius, I have WP rocket enabled; but I have tried disabling / renabling it and resetting the cache already.

    @jonathanblakoe maybe this is the problem!

    Also have WP Rocket. I’ve cleared all the caches several times, restarted Apache, Redis, Nginx, MySQL, everything. But still getting errors šŸ™

    Also reset file permissions via Cloudways panel, no luck

    • This reply was modified 1 year, 2 months ago by John.

    I’ve submitted a support ticket to Cloudways.

    Any news I’ll share here.

    Thanks, I’ll stand by for any updates!

    I too am facing the same error. I just have WooCommerce installed with theme as TwentyTwenty. First I thought there might be issues with File Permissions but all the folders do have write access. And I am facing this issue on my local installation.

    Hi guys,

    Response I’ve got from Cloudways support:
    “Please be informed that the chmod is not allowed for the app”. Just for information, on Cloudways “app” means a WordPress installation.

    So far, the warning is still showing up.

    Cheers

    Moderator Marius L. J.

    (@clorith)

    Hmm, what page are you on when seeing these errors, it’s part of WordPress’ file handling process to make sure the right owner has control of files that are added and/or uploaded, so if we can narrow down the scenario where it happens, we can possibly find a oslution here.

    Hello @clorith,

    Updating here, I’ve changed to a new server on Cloudways, and after that the warnings have disappeared. I guess it was a problem with file user ownership. At Cloudways, there is a “master” user, which is at server level, and “sub” users, for each “app” (WP installs) inside the server. Anyway, now the problem is solved.

    Thanks for your help

    Hi John,

    Thanks for the update and suggestions. I’m still having the issue, and not sure that I want to clone or change servers on Cloudways, so I will try to see if I can fix it in some other way!

    I’m seeing the same warnings, over a thousand of them each day, since the upgrade to 5.3. I’d really like to know which files WordPress is trying to chmod() in my user’s home directory, but the warning doesn’t say — and I don’t get a stack trace, so I don’t know if this is a legit piece of WordPress trying to change permissions across a thousand files, or if this is some misbehaving piece of code that I should uninstall that’s calling class-wp-filesystem-direct.php::chmod()

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Warning: chmod(): Operation not permitted after WordPress 5.3 update’ is closed to new replies.