Support » Installing WordPress » “Warning: Cannot modify header information – headers already sent”

  • I get this error in the wp login page after i installed it:

    Warning: Cannot modify header information – headers already sent by (output started at /home/name/public_html/blog/wp-config.php:34) in /home/name/public_html/blog/wp-login.php on line 42

    And I can’t login. It gives me another error…

Viewing 13 replies - 1 through 13 (of 13 total)
  • When you created wp-config.php did you accidentally include any blank lines/spaces at the beginning or end of the file?

    I don’t know =X but i fixed it…

    maybe it’s caz i edited the wp-config.php in the wordprocessor and stuff…

    caz all those php just shows up in one line… can anyone tell me howta fix that?

    wirrux: I don’t mean to sound cranky, but have you actually a) searched the forum for “cannot modify header information” and b) read the documentation?

    Many here are happy to help, but this error must be the most common ever, and has been explained hundreds of times or more.

    P.S.: Never, ever use a word processor to edit config files.

    Yes… i agree that you’re cranky… =P

    I did search the forum for that and didn’t find anything that matched. And I just read the documentation and it doesnt have what I was looking for. Plus I solved it already.. so…

    And during that time, I was really desperate. And one post in the forum isn’t going to affect you, so…

    Anyways, so does anyone know howto make it so the php codes for me doesnt appear all in one line? I think the same happens to css I download too. =(

    Moderator James Huff


    If you had searched the forums, you have found this:

    I would suggest that you start a new thread for your new question, after you have done a search.

    I had found that:
    It didn’t help the problem… n I solved it awhile ago…

    And i do search!! wtf are all you people assuming that I don’t search??…

    What specifically about the Codex page did you find lacking?

    Also, be aware that if you can’t maintain a civil tone on your posts, they will be moderated.

    The reason that it was “assumed” you didn’t search is because your question has literally been asked dozens of times. It’s not a new problem, and is very well documented throughout these forums and on many sites maintained by WP users. We “assumed” that you didn’t search because to us, looking at a list of thread after thread of the same issue, we couldn’t understand how you did NOT find a result in your search. I guess we should not have assumed.

    Moderator James Huff


    Sorry, I just have to clarify something.

    “dozens of times” = dozens of times, daily


    Sorry, right now I can’t discern what your question is. Or how you’d have otherwise solved your first problem.

    I’ve solved my problem since my 2nd post in this thread.

    I just dont understand why you all say I don’t search and that it had been asked before when I did say I did search and it wasn’t the same problem. I was just so frustrated. And still you guys are insulting me. =(

    Moderator Michael Adams (mdawaffe)



    @wirrux: I really don’t want to jump into the fray here, so I’ll simply ignore the matter of searching, I suggest you do the same if you respond.

    If you have not solved the issue you brought up as your second question, NuclearMoose is right:

    Search for an answer (easy there, it’s advice I’d give anyone). If you don’t find an answer, start a new thread; It will make it easier for other people to find help on the same issue later if the question has it’s own thread.

    okay.. thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘“Warning: Cannot modify header information – headers already sent”’ is closed to new replies.