Support » Plugin: Under Construction » Warning: Cannot modify header information – headers already sent by class-wp-que

  • Resolved steindialog

    (@steindialog)


    Dear support team,

    after the plugin activation, I’m getting a warning error displayed:

    [18-May-2020 09:59:16 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/wussleri/public_html/sites/steindialog/wp/wp-includes/class-wp-query.php:3994) in /…/wp-content/plugins/under-construction-page/under-construction.php on line 250

    [18-May-2020 09:59:16 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /…/wp-content/plugins/under-construction-page/under-construction.php on line 254

    Please help to solve that issue

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • @steindialog that seems to be a conflict with other plugin. Are the warning only showing when you activate it, or after activated you are always seeing it?

    Thread Starter steindialog

    (@steindialog)

    Hi Manuel,

    I have added this in wp-config.php
    define( ‘WP_DEBUG’, true );

    and therefore I see it always if the plugin is activated.
    If I de-activate the warning is gone.

    BR; Alex

    @steindialog tested on my side and it doesn’t work… seems a conflict with other plugin. Can You provide me a list of installed plugins?

    Thread Starter steindialog

    (@steindialog)

    Dear Manuel,

    please find here a list of all 30 activated plugins:

    Add-on WooCommerce MailPoet 3
    Akismet Anti-Spam
    Cloudflare Flexible SSL
    Contact Form 7
    Contact Form 7 Captcha
    Contact Form 7 Skins
    Duplicate Page
    EWWW Image Optimizer
    Flamingo
    Font Awesome
    Gutenberg
    Health Check & Troubleshooting
    Honeypot for Contact Form 7
    Insert Headers and Footers
    Jetpack von WordPress.com
    MailPoet 3 (New)
    Members
    Product CSV Import Export (BASIC)
    Redirection for Contact Form 7
    Shortcodes Ultimate
    Simple Google reCAPTCHA
    Ultimate FAQ
    WooCommerce
    WooCommerce Services
    WP Mail Logging
    WP Mail SMTP
    WP Staging
    Yoast SEO

    Those 21 are inactive plugins:

    Automated DHL Express Shipping
    CF7 DatePicker
    Contact Form 7 Conditional Fields
    Contact Form CFDB7
    DHL for WooCommerce
    Elementor
    ElementsKit Lite
    Facebook for WooCommerce
    Germanized für WooCommerce
    Glue for Yoast SEO & AMP
    Google Fonts Typography
    Google Tag Manager for WordPress
    Hello Dolly
    Insert HTML Snippet
    Order / Coupon / Subscription Export Import Plugin for WooCommerce (BASIC)
    Really Simple SSL
    SSL Insecure Content Fixer
    The GDPR Framework
    WooCommerce Admin
    Woody ad snippets (PHP snippets | Insert PHP)
    Wordfence Security

    Even if I switch the theme to “twentytwenty” the error notice is still alive:
    Screenshot > https://www.screencast.com/t/G9iBMev3yqU

    BR, Alex

    • This reply was modified 2 years, 1 month ago by steindialog.
    • This reply was modified 2 years, 1 month ago by steindialog.
    Thread Starter steindialog

    (@steindialog)

    Dear Manuel,

    menawhile I could find the plugin which makes the issue.
    It’s the “Add-on WooCommerce – MailPoet 3

    If I deactivate that, then those error messages are gone.

    Unfortunately I get no response from their support with the tread so far.

    Maybe you have an idea in – how to solve that.

    BR, Alex

    @steindialog in fact those warnings were not generated from our plugin.

    I cannot help you with that plugin because I don’t know it. As far as I understand it seems to be an issue that the plugin is not getting an expected post?! Don’t know. You will probably have to look into the plugin code and try to understand why.

    But as this is just warning/notice messages I would not give such importance… If the plugin is doing is job those messages will go away as soon as you disable the wp_debug…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Warning: Cannot modify header information – headers already sent by class-wp-que’ is closed to new replies.