Support » Fixing WordPress » Warning: Cannot modify header information – headers already sent

  • I’ve seen similar issues to this one in the forum, but all of the suggested fixes haven’t worked. All I’m trying to do is move a Thesis 1.85 site from one domain ( to another ( I altered the wp-config.php file to reflect the new domain, exported the old tables, did a search and replace to change the table entries to travelerpaul instead of teacherpaul, and imported the tables to the new database.

    No matter what I try, I get this error:
    Warning: Cannot modify header information – headers already sent by (output started at /home/paulswanson22/ in /home/paulswanson22/ on line 876

    Everything works fine on the site, and I can view the, but when I try to log in wp-admin, I get that message. Line 876 of the pluggable.php file reads:

    header(“Location: $location”, true, $status);

    It is the exact same file that works fine on the other site. In one forum message it suggested that I save the tables as ANSI rather than utf8 format. I tried this, and it didn’t work. I’ve moved WordPress sites from one domain to another in the past and never had any problems. Please help!!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey there!

    I’m hoping to help YOU and everyone who has this bloody error once and for all. This worked for me, and I sure hope it works for you. I once had the issue happen on my site over at: not once, but THREE times, and have safely recovered it after many head-bangs against the computer keyboard (lol).

    (*Note: I’ve tried the whole <ob_flush> and removing “blank lines” from the other help files, and nothing worked at all – what I’m about to share was the only thing that worked for me*)

    Here we go. First off, you need to know WHERE the issue is coming from. Let’s use your error as an example:

    Warning: Cannot modify header information – headers already sent by (output started at /home/paulswanson22/ in /home/paulswanson22/ on line 876

    Now, the BOLDED section is the culprit. Not pluggable.php. So, what you have to do is go into your FTP (use a FTP host like Dreamweaver, FTP, etc. – if you don’t have one, you can also try to go into your FileManager with CPanel or whatever service your host runs on).

    Step 1. Go into /wp-content/themes/thesis_185/custom/custom_functions.php (or whatever the location is showing in the first set of parenthesis) Copy (CTRL-C) the entire document – no more, no less.

    Step 2. Open NOTEPAD in Windows and PASTE (CTRL-V) the entire document into notepad. Go to the top of the file and make sure there is no extra space before <? php and at the end of the document make sure there is no extra space after ?>

    Step 3. Save AS in Notepad. Rename the file to custom_functions.php (the original file located in Step 1).

    Step 4. Go into your FTP/File Manager, and upload the PHP file. It will probably ask you if you want to overwrite the file (because it already exists) – YES you do want to overwrite it (just make sure it matches the copy/paste you did in steps 1 and 2.

    Step 5. Refresh your Browser, and the original error message *Should* go away.

    But wait…there may be more!

    Then, it might flash another error, instead of /wp-content/themes/thesis_185/custom/custom_functions.php as the culprit, it may throw something random like /wp-content/plugins/someplugin/theplugin.php. For example, the error would then show something like:

    Warning: Cannot modify header information – headers already sent by (output started at /home/paulswanson22/ in /home/paulswanson22/ on line 876

    How to fix it? Follow steps 1-5, finding this new file under wp-content/plugins.

    After that, YES – it may happen yet again. A new error code! This time it might even be pluggable.php, or wp-login. Regardless, just keep following steps 1-5 until it clears up. There was one time I had to do this for 9 or 10 times before it stopped showing all of the errors.

    The key is finding whatever file is showing up first (in this example, in the bolded piece above) and doing Step 1-5.

    I sure hope this helps. It may not work for everyone, but after trying all of the other help files with no luck, this was what worked for me!

    If you have any questions or need clarification, let me know.



    Excellent fix. I was skeptic at first, but after wasting 2 hours trying other fixes I used yours. Opened the custom_functions.php file in Dreamweaver and copied everything over to Notepad. Easy…


    CoolRunLT Thanks Man!!
    U r life saver!!

    Thanks a lot CoolRun, that worked like a charm šŸ™‚

    I’m stuck. There are multiple error codes and I don’t have NOTEPAD.

    CoolRunL, it worked! thx a lot…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Warning: Cannot modify header information – headers already sent’ is closed to new replies.