WordPress.org

Forums

Warning - Cannot Modify Header Information!!!! (13 posts)

  1. raphievila
    Member
    Posted 6 years ago #

    I'm receiving this message on the screen when trying to install wordpress...

    <strong>Warning:</strong> Cannot modify header information - headers already sent by (output started at /home/content/t/o/o/toolba00/html/rafit00/raphiee/armortail/wp-config.php:1) in raphiee/armortail/wp-includes/pluggable.php on line 850

    How can I fix this problem?

  2. s_ha_dum
    Member
    Posted 6 years ago #

    Check wp-config.php for any stray characters. It shouldn't be printing anything at all to screen. Maybe you have a bad comment block, for example.

  3. Samuel B
    moderator
    Posted 6 years ago #

  4. iron1
    Member
    Posted 6 years ago #

    This is the info I was looking for..Thanks

  5. mattblog
    Member
    Posted 5 years ago #

    I'm also having the same problem. The troubleshooing page does not do anything for me and I have been scratching my head for the last 24 hours. PLEASE HELP.

    Warning: Cannot modify header information - headers already sent by (output started at /websites/123reg/LinuxPackage21/ni/nt/en/MYDOMAIN.co.uk/public_html/wordpress/wp-config.php:1) in /websites/123reg/LinuxPackage21/ni/nt/en/MYDOMAIN.co.uk/public_html/wordpress/wp-admin/install.php on line 36

    I have removed the white space and I have added ?> with no space after but nada.
    I have also re-configured the sample page 3 times thinking i might have entered an error. but nada!!!

  6. bh_WP_fan
    Member
    Posted 5 years ago #

    /websites/123reg/LinuxPackage21/ni/nt/en/MYDOMAIN.co.uk/public_html/wordpress/wp-config.php:1 suggests that the whitespace is on the very first line of wp-config.php, before the opening php statement. Better double check your wp-config.php file.

    You may need to upload your files again, including the wp-config.php, just make sure your settings are backed up and can be put into the new wp-config.php.

  7. mattblog
    Member
    Posted 5 years ago #

    Thanks Bh_wp_Fan,

    I have done all this as stated in the Trouble shooting page. I have copied the code of the first 18 lines in wp-config.php there is no lines before the opening comand can you see anything or do i need to seed you the whole page of code?

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME',
  8. whooami
    Member
    Posted 5 years ago #

    you will NOT see stray chars or line breaks in a paste.

  9. mattblog
    Member
    Posted 5 years ago #

    I am just trying to move forward in the fastest way possible.

    This is brand new to me and I'm trying to learn how to do this without one click installations because I'm extremely interested to figure out how things are programmed and uploaded.

    This upload is a new blog and there is nothing on the server apart from the database which has been setup for this blog, which I did in the configuration.

    Does anyone else think I should remove all files from the server and start again as I don't see any stray characters or line breaks on line one or last entry.

    Any advice would be most appreciated :)

  10. whooami
    Member
    Posted 5 years ago #

    I don't see any stray characters or line breaks ...

    You wont see hidden chars.

    ...on line one or last entry

    websites/123reg/LinuxPackage21/ni/nt/en/MYDOMAIN.co.uk/public_html/wordpress/wp-config.php:1 suggests that the whitespace is on the very first line of wp-config.php, before the opening php statement. Better double check your wp-config.php file

    As was said before, the issue is before the opening <?php tag.

    If you cannot solve it, re-create the file using another sample file. Use a DIFFERENT editor; a plain text editor.

    I am just trying to move forward in the fastest way possible.

    Obviously.

  11. mattblog
    Member
    Posted 5 years ago #

    Hi Whooami,

    Thanks for your help. What I did was:
    1. Deleted all the files in Filezilla
    2. Created a new folder with wordpress extracted
    3. Opened the wp-config-sample.php and saved another copy without changing anything and called it wp-config.php
    4. Uploaded all the files from my new folder to filezilla
    5. Went to http://www.mysite.co.uk/wp-admin/setup-config.php
    6. Filled in server info
    BING BANG BONG BABY!!!

    Now the only problem I have is moving the blog from http://www.mysite.co.uk/wordpress to the index page using filezilla
    I do think I know how to recreate the database for this but it is moving the files to index I have a problem with in Filezilla.
    Any help would be appreciated. I have done some research but found nothing on Filezilla.

    thanks again!

  12. mattblog
    Member
    Posted 5 years ago #

    Done it.

    Thanks again. I'm sure I will be back with some more problems!!!

    Regards
    Matt

  13. raphievila
    Member
    Posted 5 years ago #

    Sorry, I forgot to thank everyone for your help... All solutions worked out good.

    But the main reason for my problem was that the wp-config.php had a space before the php tags. I removed them and voilá, problem solved.

    Then later on I had another issue with the same problem, I did removed the space before the php tags but didn't work. So I follow all you guys instructions and... what can I say?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic