WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Warning : cannot modify header information

[Resolved] Warning : cannot modify header information

  • Hi everybody,

    I’m actually having an issue with one of the websites I’m working on.
    When I want to access my admin panel, login in /wp-admin, I get this message :

    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries.php on line 33
    
    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries.php on line 33
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-login.php on line 414
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-login.php on line 426

    I write my login and password, and then on “connexion”, I get the same login page, but the message has changed :

    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries.php on line 33
    
    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries.php on line 33
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-login.php on line 414
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-login.php on line 426
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-includes/pluggable.php on line 861
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-includes/pluggable.php on line 862
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-includes/pluggable.php on line 863

    These issues appears just after I tried to improve the security of the (future) website, with the “Ithemes security” plugin.

    These are informations I can give you :
    – WP 3.9 (I’m not sure… could be 3.9.1)
    – PHP 5.4
    – website url : http://s534383376.onlinehome.fr/
    – The website is currently empty, I had to start working on it today !

    Is there anyone here to help me ? I searched on the web, but I’m a begginer with CMS, and I never met this kind of issue before… I’m affraid of making things worse if I modify some code lines without knowing what I’m precisely doing… Ask me if you need other informations that could help !

    Thank you ! (and excuse my bad english, I’m french !)

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Please give this link a read.

    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    I’m affraid of making things worse if I modify some code lines without knowing what I’m precisely doing… Ask me if you need other informations that could help !

    Try this: before you make any changes, save a copy of your wp-config.phpfile to wp-config-SAVE.php. That way if you make a mistake editing that file you can go back to the way it was via that copy.

    Once that copy is saved (really, please make that copy) then do the following:

    1. Copy wp-config-sample.php to wp-config.php. That will overwrite the existing file (please make that backup copy first!)
    2. Once that’s done use the most plain text editor you have and edit that new wp-config.php file. In Windows notepad is perfect for this.
    3. In that file carefully edit the values for these lines. Use the data from your wp-config-SAVE.php file.

      // ** MySQL settings - You can get this info from your web host ** //
      /** The name of the database for WordPress */
      define('DB_NAME', 'database_name_here');
      
      /** MySQL database username */
      define('DB_USER', 'username_here');
      
      /** MySQL database password */
      define('DB_PASSWORD', 'password_here');
      
      /** MySQL hostname */
      define('DB_HOST', 'localhost');

      Once that’s done save your file.

    See if you can get into your site after that.

    Hi Jan, and thank you for your quick answer.
    I red this page a few hours ago, but it didn’t resolve my issue.

    I just follow your instructions, creating wp-config-SAVE.php, overwriting my wp-config.php with wp-config-sample.php, and editing my database informations … but it still doesn’t work, sorry :/

    Any other idea ?

    Thank you,
    Have a nice day.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    It also can be your theme so try these steps:

    1. Using FTP or whatever file management tools your host has provided you with navigate to the wp-content/themes directory.
    2. Once there locate and backup the enfold directory. Don’t delete it (yet) but make a copy just in case.
    3. Once you have the backup of that enfold directory now delete it. Just that one enfold directory and nothing else.
    4. Try and re-login to your WordPress dashboard via http://s534383376.onlinehome.fr/wp-admin/themes.php and see what it says.

    Please make sure if you make that backup. These steps should default you to the Twenty Fourteen theme and you may be able to get in after that.

    Hi,

    So I just did what you told me, and here is the answer I get :

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/45/d534383371/htdocs/wp-config.php:1) in /homepages/45/d534383371/htdocs/wp-includes/pluggable.php on line 1121

    Do you think deleting everything (database and ftp content) and installing everything again could be a solution ?
    The website is currently empty (no pages, posts, or anything else), so it’s not a big deal. But I’d like to understand where does this problem come from, and how to fix it !

    Thank you for your help,
    best regards,
    Noemie 🙂

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    That’s a little harsh but yes that should work.

    If you do go that route can you let the wp-config.php file be created by the install script?

    http://s534383376.onlinehome.fr/wp-admin/install.php

    That should generate a problem free file if that’s the issue.

    STOP!
    By my reading it is the “Ithemes security” plugin that is causing the problem. Disable this plugin via FTP and see what happens.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    I’m not disagreeing with you but how did you arrive at iThemes security plugin? The plugin is there on the site so it could be that somehow.

    http://s534383376.onlinehome.fr/wp-content/plugins/better-wp-security/readme.txt

    Jan, at the end of the first post it says:

    These issues appears just after I tried to improve the security of the (future) website, with the “Ithemes security” plugin.

    When I see “JUST AFTER”, I think it may be a cause.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    I totally missed that. Good catch. 😉

    Hi !
    Thanks for your answers, but it didn’t fixed the issue :/
    I really don’t understand where the problem comes from…

    I think I’ll delete everything and then re-install it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Warning : cannot modify header information’ is closed to new replies.
Skip to toolbar