WordPress.org

Forums

[resolved] Warning: Cannot modify header information (10 posts)

  1. caitlin1202
    Member
    Posted 9 years ago #

    Warning: Cannot modify header information - headers already sent by (output started at /home/spilling/public_html/wp-config.php:47) in /home/spilling/public_html/wp-admin/inline-uploading.php on line 138

    I get this message when I try to edit posts. Anyone know what it means?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Yup - and it's easy to fix.

    Download wp-config.php
    Open in a plain text editor
    Scroll to the very end and you'll see
    ?>
    Put the cursor between those two characters, then hold DELETE on your keyboard for 10 seconds.
    Then press > and save the file without touching anything else - no more keypresses. Upload and it should be good.

  3. caitlin1202
    Member
    Posted 9 years ago #

    Thanks, can you be more specific about what I'm deleting?
    This is what I see towards the end of the wp-config document : can you show me what it should look like?

    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');

    require_once(ABSPATH.'wp-settings.php');

    ?>

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    That last

    ?>

    Delete the >
    hold delete for 10 seconds
    Press >
    then save without pressing another key.

  5. skulled
    Member
    Posted 9 years ago #

    It should look exactly the same as you have it now.

    But there seems to be some whitespace added in your wp-config.php file which is giving the warning.

    So basically by following the method podz outlined, you are making sure you have no whitespaces/extra stuff that some editors place.

  6. caitlin1202
    Member
    Posted 9 years ago #

    :( sorry. Still am not understanding. I opened the file in my text editor and deleted all the white space, but I'm still getting the same error mesage:

    <?php
    // ** MySQL settings ** //
    define ( 'DB_NAME' , 'spilling_wrdp1' ) ; // The name of the database
    define ( 'DB_USER' , 'spilling_wrdp1' ) ; // Your MySQL username
    define ( 'DB_PASSWORD' , 'dqV70UxP8jKv' ) ; // ...and password
    define ( 'DB_HOST' , 'localhost' ) ; // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* Stop editing */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    `/* Stop editing */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    The white space is after the last
    ?>

    It't not before then, just after then.

  8. skulled
    Member
    Posted 9 years ago #

    what editor are you using?

  9. jaredquinn
    Member
    Posted 9 years ago #

    What podz is trying to get you to do is to open the wp-config.php file and delete all of the whitespace between the last ?> and the end of the file.

    The ?> must be on the last line of the file with nothing following it.

  10. caitlin1202
    Member
    Posted 9 years ago #

    Thank you, it was the white space after.

Topic Closed

This topic has been closed to new replies.

About this Topic