Support » Plugin: BackWPup - WordPress Backup Plugin » Warning: call_user_func_array parameter issue

  • Resolved Jeff Lambert

    (@lambje)


    I’m looking at the error log for a multisite (3 sites) that I’m performing maintenance on today. Each day I get the following error repeated 6 times:

    [16-May-2018 13:39:04 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘BackWPup_Cron’ does not have a method ‘update_message’ in /home/markengl/public_html/wp-includes/class-wp-hook.php on line 286

    I’m running v3.4.5 of BackWPup and v9.4.5 of WP.

    While unrelated, this multisite is the same one that I was getting 3 backups created each day instead of the 1. I did put in a fix from that thread, which fixed that issue.

    Thanks for the plugin!

    Cheers,

    Jeff

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    @lambje
    Could you please give me your PHP info?
    go to BackWPUp -> Settings -> Infomation -> and press “Get debug info”

    Thread Starter Jeff Lambert

    (@lambje)

    Sure @duongcuong96:

    WordPress version: 4.9.5
    BackWPup version: 3.4.5
    PHP version: 7.0.30 (64bit)
    MySQL version: 5.6.38
    cURL version: 7.59.0
    cURL SSL version: OpenSSL/1.0.2o
    WP-Cron url: https://greencomplianceplus.markenglisharchitects.com/wp-cron.php
    Server self connect: Response Test O.K.
    Document root: redacted
    Temp folder: redacted/wp-content/uploads/backwpup-154ef9-temp/
    Log folder: redacted/wp-content/uploads/backwpup-154ef9-logs/
    Server: Apache
    Operating System: Linux
    PHP SAPI: apache2handler
    Current PHP user: markengl
    Maximum execution time: 300 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 5:13
    Blog Time: 22:13
    Blog Timezone: America/Los_Angeles
    Blog Time offset: -7 hours
    Blog language: en-US
    MySQL Client encoding: utf8
    PHP Memory limit: 268435456
    WP memory limit: 64M
    WP maximum memory limit: 256M
    Memory in use: 10.00 MB
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, apache2handler, bcmath, bz2, calendar, ctype, curl, date, dom, exif, filter, ftp, gd, gettext, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, session, soap, sockets, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    Plugin Support Andreas W.

    (@aweissinpsyde)

    Hi @all,

    we have a new version on github fixing bugs of 3.5.0. You can download it here https://github.com/inpsyde/backwpup/archive/master.zip.
    Would be great if we get some feedback before we release on wordpress.org.

    Thanks a lot for your help!

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi there,
    The new 3.5.1 version has been released with bugs fixed, please update as soon as possible.
    If you still have any problem, just let me know 🙂

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/
    Thank you 🙂

    Thread Starter Jeff Lambert

    (@lambje)

    Hello @duongcuong96 — I installed 3.5.1 a few days ago and it fixed the multi-instance backups in multisite and also checked the error log and haven’t gotten the error noted in this ticket since the upgrade. Thanks for the fixes and the plugin. Left a review.

    Cheers,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Warning: call_user_func_array parameter issue’ is closed to new replies.