Support » Plugin: Timeline Express » Warning: call_user_func_array() expects parameter 1 to be a valid callback

  • Hi,

    When I try to use the plugin, it throws me the warning (‘Warning: call_user_func_array() expects parameter 1 to be a valid callback, second array member is not a valid method in …/wp-includes/class-wp-hook.php on line 286.

    I’ve tried uninstalling it and installing again, and removing my previous announcements but nothing seems to work, I can never get rid of this warning even if there are no announcements when the plugin is on and I use the [timeline-express] code.

    Could it be some field on the database that the plugin uses and it’s causing the warning?

    Thanks in advance

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Code Parrots

    (@codeparrots)

    Hi @fridaymood,

    Where is that error message visible and when does it occur?

    It sounds like there may be a function that is being referenced that doesn’t actually exist, but I’m not 100% sure of where that error is being thrown. That error doesn’t specify any file in our plugin or any function names.

    Hello @codeparrots,

    The error is shown in the first line of the website, above the top bar. It only occurs when the plugin is enabled and I use [timeline-express].

    The timeline output works well, but this message keeps appearing.

    Plugin Contributor Code Parrots

    (@codeparrots)

    We will do some quick testing to see if we can also reproduce the issue. If so, we will certainly push out an update fairly quickly to get the issue resolved.

    We will post back here shortly with some findings!

    Plugin Contributor Code Parrots

    (@codeparrots)

    I’m not seeing that same error at the top of the page where the timeline is output. Do you have a link to that page?

    Plugin Contributor Code Parrots

    (@codeparrots)

    Are you using any of our add-ons alongside Timeline Express? Have you tried disabling other plugins to confirm that it is our plugin causing the issue? Is this the free or the pro version? I’m guessing this is the free version downloaded through your WordPress dashboard or from WordPress.org directly.

    Yes, its the free version. I’ve tried both installing through the WordPress dashboard and downloading your plugin from the website and installing the zip.

    All the cache and optimization plugins are disabled, so I don’t think any other is interfering.

    I was using the single column add-on, but I totally removed it. When I fix this warning on the main plugin I’ll try installing the add-on again.

    The website is under development yet, so I can’t provide a link.

    • This reply was modified 1 year, 2 months ago by fridaymood.

    Maybe its a compatibility issue with your plugin and the theme, could it be?

    I’m using the latest version of Pxlz theme from Edge-Themes.

    Plugin Contributor Code Parrots

    (@codeparrots)

    It’s possible, but you generally wouldn’t see a php warnings like that. It seems like something else may be at play. Have you tried temporarily switching themes to something like TwentySeventeen, and only having Timeline Express active? I can’t download Pxlz since it’s a premium theme from theme forest.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Warning: call_user_func_array() expects parameter 1 to be a valid callback’ is closed to new replies.