WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » Warning: call_user_func_array()

Warning: call_user_func_array()

Viewing 15 replies - 16 through 30 (of 44 total)
  • Yeah, seeing the same. I have Cheope 1.4.1 with WooCommerce 2.0.1 and they are not playing well together.

    I see the following at the top of every admin page right now:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘woocommerce_price_filter_init’ not found or invalid function name…

    In addition, the shop page lists my products but when I click on any of those products I get a 404 file not found. Not sure what that is about but I’m glad this is just a development site right now….

    On the theme page (themeforest.net) the author says that they are working for an update to the Cheope theme as of 7 hours ago. Here is the exact message from her on that site:

    “Today we will work on this. We had already a beta version of the theme compatible with woo commerce 2.0 but Friday the woo commerce team changed a lot of settings in the plugin so now we have to work again on this changes. Today or tomorrow we will send the update of the theme with the full compatibilty. thanks”

    @jeroenvanderschenk can you send me the old plugin?
    contact@splendidangst.com

    Roy Ho

    @splashingpixelscom

    You can’t go back once you updated to 2.0 unless you restore the database.

    Damn. Thank you

    Roy Ho

    @splashingpixelscom

    Well this is given you pressed the “RUN UPDATER” button already…there is a clear message that says once you update, you can’t go back…So if you haven’t already clicked that, then you can simply copy the 1.6.6 files back otherwise you need to restore.

    I am having this same issue, so you are saying restore the database on my hosting site.

    Plugin Author Mike Jolley

    @mikejolley

    Odd – the action and function (woocommerce_price_filter_init) are right next to one another – the callback is valid.

    Maybe you guys are running either a theme or another plugin which breaks this? If you start turning things off you can narrow down the issue.

    after update woocommerce to 2.0 i got this warning

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘woocommerce_price_filter_init’ was given in /home/shopeemy/public_html/wp-includes/plugin.php on line 406

    Warning: Cannot modify header information – headers already sent by (output started at /home/shopeemy/public_html/wp-includes/plugin.php:406) in /home/shopeemy/public_html/wp-includes/pluggable.php on line 876

    please!!please!!please.. fix this problem

    please send me the old version. email to boteyfx@gmail.com

    This seems to be caused from an action call (do_action) with woocommerce_price_filter_init being passed as the argument. Woocommerce_price_filter_init is not an action, it is a function that is called during an init action. plugin.php on line 406 is the “do_action” hook. However, when adding an arbitrary action called woocommerce_price_filter_init, I still continue to get the same error. It’s getting to be pretty damn frustrating.

    I found the problem in my theme. I am using Sommerce theme and discovered that there is a call to add_action(‘init’, ‘woocommerce_price_filter_init’) inside of Sommerce>inc>woocommerce.php on line 16. This is a duplicate call and is what has been causing the error. So for those of you who are having this issue, it is likely that you are using a theme (or a plugin, but I doubt it) that was made to be used with woocommerce and somewhere in the core, or admin functions of your theme in some file relating to woocommerce. Find that file and look for the now duplicated call above. Comment it out or delete it.

    Latest Cheope theme seems to work fine now, latest RC for Woocommerce 2 out yesterday, installed this morning and it resolved errors and layout issues I was seeing.

    Download one of the previous versions of woocommerce here :

    http://wordpress.org/extend/plugins/woocommerce/developers/

    dunar21, I have the Maya Shop theme that has a line in its woocommerce.php page that calls the action and commented it out like you said. It works.

    Thank you!

    I have the Maya Shop too.. and this fix worked. Thanks! Located at /inc/woocommerce.php, line 27

Viewing 15 replies - 16 through 30 (of 44 total)
  • The topic ‘Warning: call_user_func_array()’ is closed to new replies.
Skip to toolbar