Support » Plugin: All in One SEO – Best WordPress SEO Plugin – Easily Improve SEO Rankings & Increase Traffic » Warning: array_replace_recursive(): Expected parameter 2 to be an array

  • Resolved mamarabbit

    (@mamarabbit)


    Hi,
    I had a log in problem with Word press account due to all-in-one-seo-pack, got a support here and fixed the problem by using file manager and renaming the plug-in.

    Now I have these Warnings like below on dashboard and they also show up when I click wherever in my dashboard.
    For example, When I click post to edit, these Warnings show up first and disappears, then post page appears.

    Thought I should install and unistall the plugin but wonder if it affects the website?
    Could you tell me a solution please?

    Warning: array_replace_recursive(): Expected parameter 2 to be an array, string given in /home/xs998290/mamarabbit-kitchen.com/public_html/wp-content/plugins/all-in-one-seo-pack/app/Common/Utils/Options.php on line 742

    Warning: array_replace_recursive(): Expected parameter 2 to be an array, string given in /home/xs998290/mamarabbit-kitchen.com/public_html/wp-content/plugins/all-in-one-seo-pack/app/Common/Utils/Options.php on line 770

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Steve M

    (@wpsmort)

    @mamarabbit We now have a beta version of All in One SEO which should fix this. You can download the beta version here – https://www.dropbox.com/sh/3ymm9vkgtvjsayy/AABP_Q3siOv3WLVrtRKnC_Zpa?dl=0

    Please give that a try and let me know if it does, or doesn’t work.

    I had the same problem and the fix works.
    Best regards
    dUDLAJ

    • This reply was modified 1 year, 2 months ago by dudlaj.

    Hello,

    This issue has occurred since version 4.1.1.1, now over 10 days ago.
    This error message appears on the site even if WP_DEBUG is false.

    I am sorry but I do not find this serious, I manage many sites and unfortunately I do not activate the automatic update.
    Please, what are you waiting for to provide an update to fix this problem?
    Your tool is a very good tool and it seems to me that your reputation is at stake.

    Best Regards

    Stephan Renault

    Plugin Support Steve M

    (@wpsmort)

    @stephanr-1 As you can see from above, we’ve released a beta version that fixes this and the fix will be included in our next release due out very soon.

    Yes of course I saw 🙂
    But I prefer the official version. I would be patient.
    Thank you for your reply.
    Good continuation

    @wpsmort is this fix in 4.1.2.2? we seem to be encountering this on a few pages, 4.1.2.2 seemed to help with one of them but we still see this message on a couple more upon Update, and cannot update the pages so long as all in one is turned on.

    if there’s a github issue that i can read up on that has more details about what causes it from a technical perspective i’d be glad to read it.

    Hope you’re well!

    @wpsmort just to update, I found a github issue stating that the problem is fixed in 4.1.2.2 but data corruption in affected pages can cause the issue to continue on those pages. We will get 4.1.2.2 out on our production site this weekend and then re-create the affected pages after update. Because we’re on an intranet and behind a firewall, we can’t share our data for cleanup as the github issue suggests.

    Plugin Author arnaudbroes

    (@arnaudbroes)

    Hey @spacegrrl,

    I’m the developer who worked on a fix for the issue you’re experiencing.

    We’re fixing the issue in 4.1.3 in the sense that it will no longer be able to occur going forward. However, any data that has already been affected will not automatically be fixed, simply because we’re not able to automatically detect which sites have been affected (very limited amount). So that’s why the “cleaning” procedure as I like to call it needs to be triggered manually.

    If you could reach out to us at https://aioseo.com/contact (click the “Submit a Form” button) and ask for me, I’d be happy to instruct you on how you can run this cleaning procedure and already implement the fix we are shipping in 4.1.3.

    @arnaudbroes I understand. I believe we will have to purchase a support license to be able to contact you via that form – is that correct?

    Plugin Support Steve M

    (@wpsmort)

    Hi Lisa (@spacegrrl), You can use the normal contact form to reach us.

    @wpsmort thank you! contact form sent.

    Plugin Author arnaudbroes

    (@arnaudbroes)

    Hey @spacegrrl,

    Just as an FYI, I responded last week. If you have not seen my reply yet, definitely check your spam box.

    @arnaudbroes – got it! thank you for the quick response.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Warning: array_replace_recursive(): Expected parameter 2 to be an array’ is closed to new replies.