Support » Plugin: WooCommerce » Warning: array_merge

  • Resolved annaevtushenko

    (@annaevtushenko)


    Updated the plugin to the new version. On pages where there is a “add to cart” button, an error has appeared Warning: array_merge(): Expected parameter 1 to be an array, bool given in …./wp-content/plugins/elementor/includes/base/controls-stack.php on line 1184

    Solution to the problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same goes for my website.

    Plugin Support 3 Sons Development – a11n

    (@3sonsdevelopment)

    Does this happen when Elementor is disabled? You can test by using the Health Check plugin’s troubleshooting mode. It will let you disabled everything on your site except for WooCommerce and switch to one of the default themes. But it only affects logged in users so your customers won’t be affected.

    See if you get this message with only the default theme and WooCommerce active. If you do let me know. If it only happens with Elementor active, then you’ll want to get in touch with their support to let them know about the issue.

    You’ll probably also want to disable PHP notices for customers. This type of warning it typically for developers to see and not intended for general users (customers) to see.

    There is a guide for how to do this on WP Beginner

    https://www.wpbeginner.com/wp-tutorials/how-to-turn-off-php-errors-in-wordpress/

    Cheers

    Thread Starter annaevtushenko

    (@annaevtushenko)

    Three Sons (@3sonsdevelopment), Thanks!

    Thank you so much for this guidance!
    For me, it turned out to be Elementor version newer than 2.8.5.
    Will wait for the next Elementor update.
    Cheers

    It works good for me. Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Warning: array_merge’ is closed to new replies.