Support » Plugin: Meal Planner Pro Recipes » Warning: array_keys() expects parameter

  • Resolved ThePureTaste

    (@thepuretaste)


    Hi,

    This is the message I see when I open Mealplannerpro recipe button in the post:

    Warning: array_keys() expects parameter 1 to be array, null given in /home/thepur21/public_html/wp-content/plugins/meal-planner-pro/mpprecipe.php on line 2383

    Warning: Invalid argument supplied for foreach() in /home/thepur21/public_html/wp-content/plugins/meal-planner-pro/mpprecipe.php on line 2384

    Is this something wrong with the plugin or with my theme?

    Thanks,
    Maria

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Meal Planner Pro

    (@mealplannerpro)

    Hmm…not sure. Could you please send us a link to one of your recipes so we can look into it? support(at)mealplannerpro(dot)com

    Plugin Author Meal Planner Pro

    (@mealplannerpro)

    P.S. – no need to send link. I was able to find your site. We’ll look into the issue and let you know soon.

    Thanks

    Thread Starter ThePureTaste

    (@thepuretaste)

    Great.
    Thank you so much for looking into it.

    jbouwmeesterwordpress

    (@jbouwmeesterwordpress)

    Any update on this? I’m running into the same issue.

    Plugin Author Meal Planner Pro

    (@mealplannerpro)

    I’ve sent this to the dev team to look into. We’ve had very few reports of the issue which makes it more difficult to diagnose. It’s high priority.

    Thanks for your patience.

    Plugin Author Meal Planner Pro

    (@mealplannerpro)

    FYI – the array error message issue should now be fixed. Please update to the new plugin version 7.8.1.3 . Can you then please let us know if the issue is resolved>

    Thanks!

    Thread Starter ThePureTaste

    (@thepuretaste)

    Hi,

    So far looks good! Thank you for fixing it in.

    Just a quick question, though. Will you make this plugin compatible with Gutenberg?
    As I understood a lot of changes are coming, and a lot of plugins are planning to drop off. Saying there will be too much work…

    Thanks,
    Maria

    Plugin Author Meal Planner Pro

    (@mealplannerpro)

    We’re working on Gutenburg compatibility now. Fortunately our plugin won’t require as much recoding as some of the others. You can read more details about this in a previous support ticket if you wish. About 2-3 weeks to complete.

    Thread Starter ThePureTaste

    (@thepuretaste)

    Great. Thank you

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Warning: array_keys() expects parameter’ is closed to new replies.