Support » Alpha/Beta/RC » Warning: An existing WordPress network was detected.

  • Resolved MaddTechWF


    I just saw the RC build for 3.0 and decided to download it to my site and play around with it. In the root of my site I have 2.9.2 installed and working great. I created a directory called /dev/wp3 which has the RC inside it. I modified the settings like I was told in the codex but I get the error in my title. Any suggestions on what I’m doing wrong?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Are you using the same DB and the same DB prefix as your exisiting install?

    Also, did it work before you started playing with the network settings?

    Well I haven’t upgraded my stable 2.9.2 install. I’m trying to install a second WP in a subdirectory. My test WP3 works fine. I just don’t get the Super Admin section after doing the Multisite.

    I had exactly the same problem then i realize that i didn’t save the changes i made to the wp-config.php file. Maybe your problem has something to do with something missing in that file, some line of code you didn’t paste from the codex or something. Hope this helps.

    That … seems contradictory.

    Post 1 you say that you get “An existing WordPress network was detected” warning.

    Post 2 you say it’s fine, but you don’t get Super Admin.

    The first is usually because you’re pointing to a DB that has WP installed with the same prefix already.

    The second is probably define('MULTISITE', true); is missing.

    Go to

    Make sure you copied everything.

    I never read to modify the network.php. What am I suppose to do in it? I read only to change the .htaccess and the wp-config.php files.

    I didn’t say you should MODIFY it, I say you should go to that page and make sure you copy everything in that page, like it tells you.

    Edit your .htaccess and wp-config.php exactly as described. This is very important 🙂

    Also, what error are you currently facing. You’ve listed two, and it’s better to solve one, then move on to the next, rather than jump around 🙂

    Okay. I was reading my previous posts and I want to clarify quite a few things. I currently have a site being hosted that is running WP 2.9.2.

    Inside the root of the directory I have a directory called dev and inside it another directory called WP3. The BETA is inside the WP3 folder. So essentially I have 2 instances running. They both report back to the same db but one has a prefix of wp_ and the other has wp3_.

    I have modified the .htaccess and wp-config.php as I was told in the article on WP codex.

    When I go to Tools-Network I get a message box that states the following: “Warning: An existing WordPress network was detected.” I assumed that this warning had something to do with my SuperAdmin not showing up.

    I hope this clears it up a little more.

    When I go to Tools-Network I get a message box that states the following: “Warning: An existing WordPress network was detected.” I assumed that this warning had something to do with my SuperAdmin not showing up.

    Okay. On mine I get this:
    “Notice: The Network feature is already enabled. The original configuration steps are shown here for reference.”

    That means you didn’t set it up correctly somehow.

    I have modified the .htaccess and wp-config.php as I was told in the article on WP codex.

    Undo that. We’ll start over, basically 🙂

    1) Add THIS to your wp-config.php
    define('WP_ALLOW_MULTISITE', true);

    2) Go to Tools -> Network

    That should bring you to a screen that says something like this:

    Basically, what you’ve done is set it up out of sequence. I’ll talk to Andrea, who wrote that page, and see if we can’t get it cleaned up for RC1 🙂 She wrote that WAY back before Beta, when we were all still on Nightly.

    Okay. I have done that and here is what it looks like now.

    Check your database.

    Do you have tables like this:


    I think you may have a half-way installed version.

    I have that table in my db but I have attached a screenshot of what tables I have.

    And if you copy the lines from the tools -> network back into wp-config and .htaccess, you’re back with an install that won’t give you Site Admin.


    I just started up an account with Dreamhost and I’m going to try it on there. Do you have a host provider that you recommend.

    If there’s no data loss involved, delete ALL the wp3_ tables and start over. Something got out of whack, but I can’t see what it is.

    It would be exceptionally weird if it was your host. I use Liquidweb (and if you do use ’em, feel free to mention as a referral)

    May I chime in for saying thank you to camilin119!

    I also had this problem: “”An existing WordPress network was detected”

    I had been going over the whole procedure as outlined by Andrea and was (re)checking every step. Luckily I had documented for my own reference almost all the steps.

    However somewhere between the whole switche-marolah (Backende WP 3.0, jEdit, Referencedocument, shoving the stuff to and fro on the screen, etc) I had forgotten to upload the wp-config.php. It was as simple as that! And it was the remark here above of camilin119 that made me realize that it didn’t have to be a bad edit but that it could be a very simple thing.

    I am with Dreamhost since 2005. Love the guys! Always get speedy replies when I have a support request. Their control panel is a beauty. If ever you need to use the Discussions Forum, ferret out the answers by rlparker. He is one hell of a nice and very well informed guy and extremely helpful! When he answers support tickets he always gives more and quality advice then you expect.
    Are you using subdirectories or subdomains? If you plan to use absolutely subdomains for whatever reason you will find that DreamHost this only allows on Private Virtual Servers. The wild card DNS must be requested as this can only be done by the staff! Doing some asterix (*) stuff yourself won’t work! You have to give a pretty good reason why you absolutely need it, as they are not really in favour of it.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Warning: An existing WordPress network was detected.’ is closed to new replies.