Support » Networking WordPress » Warning: An existing WordPress network was detected. plus one more problem

  • Resolved Isaak Wells

    (@isaak-wells)


    I put the line, define('WP_ALLOW_MULTISITE', true); and it gives me the following warning.

    Warning: An existing WordPress network was detected.

    Also in the code instead of giving my my site consolealliance.com it gives me my other sites address as the default.
    define( 'DOMAIN_CURRENT_SITE', 'consolealliance.net' );
    It should be
    define( 'DOMAIN_CURRENT_SITE', 'consolealliance.com' );

    Can anyone explain how I may fix this?
    any suggestions or help are appreciated, Thanks.

Viewing 15 replies - 1 through 15 (of 39 total)
  • Are you sharing a database?

    Same here.

    Activated network on my primary blog and set it all up (OK so far). When I noticed that the network option didn’t really work for me, I went back to the original wp-config.php.

    Still no problem but when I add the network code to wp-config.php, I get the same message (“existing network detected”).

    btw – I cleaned the db (in which three separate wp-installations are up and running) from the network entries.

    No I am not

    Are both of you using an add-on domain at your host? And did you ask your host if they support the network (or multiste) on your account?

    I’m getting the same message attempting to install it locally for testing purposes using subdirectories.

    Actually thought I’d commented out the wp-config.php line enabling network settings, but had not. So message is gone and replaced by nothing. No network, Super Admin. Back to the original Dashboard. Database was updated with 6 new tables, nothing added to the Dashboard. No other warnings, just the old single site set-up with more tables.

    I’ve checked everything at this topic already.

    Ok, just reinstalled and network settings are now working, but WP pages are not being served to the subdirectories/sub-sites. I’ve posted a question about this at another topic.

    How do you reinstall the network settings?

    remove the global network tables, and the lines you added in the config file.

    I also had this problem: “”An existing WordPress network was detected”

    then you have some sitewide tables in the db.

    I’m having the same problems. Have you guys solved it?

    kanishqa

    (@kanishqa)

    I am kind of newbie to wordpress, but not to php. I tried network on my site, and ran into the dreaded warning message

    “Warning: An existing WordPress network was detected.”

    . After spending some time trying to figure out, I ended up peeking into network.php.

    To turn on Network, we need to add a constant, WP_ALLOW_MULTISITE. After this, when you try to install Network, it gives you the list of constants to be added to wp-config.php file. When I copied, I missed copying “define( ‘MULTISITE‘, true )” thinking this is already there. Both these constants have to be there in the wp-config.php for network to work.

    Once I fixed this, I got the message,

    “Notice: The Network feature is already enabled. …”

    which is good.

    Several sites that suggest fixes for this issue, mix up between these 2 settings as if they are one. Beware.

    Andrea – if nobody ever compared you to a saint, please allow me the privilege and honor to be the first!

    your posts have helped be before, but this one REALLY helped me with a tough problem!

    my problem was actually two-fold:

    1) the following tables had to be removed
    wp_blogs
    wp_blog_versions
    wp_site
    wp_sitemeta

    2) then i just started over from the beginning.

    also, one of the plug-ins has to be disabled every time i create a new site, and then enabled afterwards. i can live with that !

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Warning: An existing WordPress network was detected. plus one more problem’ is closed to new replies.