Support » Plugin: NextScripts: Social Networks Auto-Poster » Warning after Updating to Snap 3.8.1

  • Resolved Ivan Jaquez

    (@ivan-jaquez)



    I getting this warning message at the top on wp admin page(dashboard):

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘nxs_snap_pointer_admin_enqueue_scripts’ not found or invalid function name in /home/topbrea1/public_html/wp-includes/class-wp-hook.php on line 298

    Any help on this? Thanks for your consideration and support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author NextScripts

    (@nextscripts)

    3.8.1 is outdated.

    Please update to the latest version 3.8.2. This problem has been fixed there.

    Thanks! Take care.

    Yes its fixed but partly:

    After the new registration that error comes in again

    Plugin Author NextScripts

    (@nextscripts)

    What do you mean “new registration”? What kind of registration?

    Also are you sure it’s exact same error?

    Error literally says “function ‘nxs_snap_pointer_admin_enqueue_scripts’ not found“. That function was missing. The fix was to add function ‘nxs_snap_pointer_admin_enqueue_scripts’ to the code. So it’s kind of hard to imagine how you could you get it again. Function is now there, how could it be “not found”?

    • This reply was modified 1 year, 6 months ago by  NextScripts.
    • This reply was modified 1 year, 6 months ago by  NextScripts.

    Normal WordPress new user registration.
    The error comes after the registration. However the registration successfully generates.

    This Error:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'nxsUserProfileSettingsSave' not found or invalid function name in /home/ourwebsiteid/public_html/wp-includes/class-wp-hook.php on line 300
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/ourwebsiteid/public_html/wp-includes/class-wp-hook.php:300) in /home/ourwebsiteid/public_html/wp-includes/pluggable.php on line 1195

    Before the update of nsx this error wasnt exist.

    • This reply was modified 1 year, 5 months ago by  gameslopedy.
    • This reply was modified 1 year, 5 months ago by  gameslopedy.
    Plugin Author NextScripts

    (@nextscripts)

    So it’s a different error about different function. Thank for reporting, we will fix in the the next release.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Warning after Updating to Snap 3.8.1’ is closed to new replies.