Support » Plugin: The Events Calendar » Warning after updating – Events slug

  • Resolved Cyndi


    I guess I’m having a “blank” moment but have seen several of these on sites today and just don’t get what it means/asking us to do:

    The page “Events” uses the “/events” slug: the Events Calendar plugin will show its calendar in place of the page.

    Edit the page slug or edit The Events Calendar settings.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Getting this same error.

    When I try to edit TEC settings I get a permissions error.

    I updated the plugin, one site the message is gone, another it’s still showing. I get permissions error also.

    Same for me, but you can get to the events calendar settings if you access them from the Dashboard menu instead of the link in the warning.

    That said, once there, it is still not clear what needs to be done.

    That is what I’m confused about too.

    I’m getting this same message after the update and can’t dismiss it. Site is still working fine, but the warning/error is annoying!

    Do real employees monitor here, as I got a nasty-gram back when I wrote them about it.

    They do check this forum every Wednesday. I use the free and paid version; I asked about this in the members forum and they have a fix coming out shortly.

    Go to the plugin page then Developer and download the previous version. That removes the error.

    (3.11.2 was the previous version)

    Hopefully they will sort this out soon.

    Plugin Author Brook


    Howdy guys,

    It sounds like you are probably using pathinfo URLs, where all of your pages begin with []/index.php/[page-name]. In which case there is a now known bug that we are working on fix for. In the mean time downloading a past version, or switch your permalink to default or postname should fix it. I am truly sorry for the bug. We are adding a test to future versions to help catch this sort of bug.

    – Brook

    Hi Brook, that isn’t the case on either site. 🙁 But will await the fix. 🙂

    Plugin Author Brian



    I wanted to let you know you can remove this warning by adding the following to your theme’s functions.php:

    // remove slug conflict admin notice
    if (class_exists('Tribe__Events__Admin__Notice__Archive_Slug_Conflict')) {
      remove_action( 'admin_init', array( Tribe__Events__Admin__Notice__Archive_Slug_Conflict::instance(), 'maybe_add_admin_notice' ) );




    You can get rid of it if you have an actual page called “Events” and delete it; as the plugin doesn’t use an actual WP page. I did that on several sites and they all work fine.

    Plugin Author Brian


    Thanks for sharing Cyndi, that works too.



    You’re welcome. 🙂

    Five months later and this problem is still resident in version 4.0.7? We are not using a page named “Events” therefore that is not a fix. We are not using a child theme, therefore adding the functions.php tweak is not an option. Editing the themes functions.php is obviously overwritten when updated. Our permalinks is already set to Postname, therefore Brooks suggestion is not workable. Any idea when the plugin will be properly remedied versus workarounds?

    Hi Inndesign and thanks for the response,

    To quote the forum guidelines:

    Posting your own topic is smiled upon.

    If you can create a new post of your own that would be appreciated. Additionally, we have included a remedy in our 4.1 version.

    Thanks for choosing TEC and have a great week!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Warning after updating – Events slug’ is closed to new replies.