Support » Plugin: MailPoet - emails and newsletters in WordPress » WARNING about v 3.34.2

  • Resolved richards1052

    (@richards1052)


    I urge users to be very careful about updating to the new version: 3.34.2 After doing so my entire backend was inaccessible. I had to switch to recovery mode and disable the plugin entirely in order to regain access.

    MP has posted in another thread that 3.34.2 fixes this bug (at least if I understood the post correctly). It does not. At least not for me.

    I’ve posted the specific error thrown in that other thread. I”ll post it here as well:

    
    "An error of type E_ERROR was caused in line 346 of the file /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Models/Model.php. Error message: Uncaught exception 'Exception' with message 'could not find driver' in /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Models/Model.php:346 Stack trace: #0 /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Models/Setting.php(40): MailPoet\Models\Model::__callStatic('findMany', Array) #1 /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Models/Setting.php(40): MailPoet\Models\Setting::findMany() #2 /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Settings/SettingsController.php(116): MailPoet\Models\Setting::getAll() #3 /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Settings/SettingsController.php(24): MailPoet\Settings\SettingsController->ensureLoaded() #4 /var/www/richardsilverstein.com/public_html/wp-content/plugins/mailpoet/lib/Services/Bridge.php(66): MailPoet\Settings\SettingsController->get('premium.premium...') #5 /var/www/richardsilverstein.com/public_html/wp-content/"
    

    I now can’t use MP at all. So I hope the powers that be fix this bug. Also, I hope you can address the issue of a bug in the plugin disabling the entire backend. PLugins shouldn’t do that.

    • This topic was modified 5 months, 3 weeks ago by richards1052.
    • This topic was modified 5 months, 3 weeks ago by Jan Dembowski. Reason: Formatting

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • UPDATE: Despite reverting to v 3.30, somehow my installtion must’ve updated back to 3.34.2, the buggy version. Now I have no access to my backend. I strongly recommend eveyrone deactivate Mail Poet till the authors have fixed this bug.

    In the meantime, my host has helped me revert to V. 3.30, the last stable version. I hope Mail Poet fixes this. It’s a mess.

    Further, if you use Jetpack autoupdate you must be careful that it doesn’t automatically update you back to the new buggy version. I had to completely disable autoupdate in order to avoid that additional problem.

    • This reply was modified 5 months, 3 weeks ago by richards1052.
    • This reply was modified 5 months, 3 weeks ago by Jan Dembowski. Reason: More formatting
    Plugin Author MailPoet

    (@wysija)

    Hi there,

    This has been fixed with the latest release. Please try upgrading and everything will work fine. Any issues at all let us know.

    Note to mods: tagged modlook as there appear to be multiple formatting issues with this page breaking the display.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.