• Resolved johnyyw

    (@johnyyw)


    I purchased and acivated premium version. After installing the plugin i got this warning, if I deactivate ultimate review plugin, the warning goes away, when your plugin is activated warning appears again… How to fix this?

    Warning: A non-numeric value encountered in /home/…/public_html/wp-content/plugins/ultimate-reviews/Functions/EWD_URP_Replace_WooCommerce_Reviews.php on line 126

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter johnyyw

    (@johnyyw)

    I made a test order as verified buyer, but I can’t even post a review for product it shows this warning on review tab “Warning: A non-numeric value encountered in /home/…/public_html/wp-content/plugins/ultimate-reviews/Shortcodes/SubmitReview.php on line 629” and names of different products..

    Well I waste so many hours today enabling and disabling options on your plugin, but nothing realy works…

    Currently it just looks like a waste of money.. hope there is some easy fix.

    Currently I deactivated your plugin, so I dont have any warnings / errors

    Thread Starter johnyyw

    (@johnyyw)

    Forgot to post I was running

    WordPress 5.1.1
    WooCommerce 3.6.2
    WooCommerce Multilingual 4.6.2.1
    Ultimate Reviews 2.1.16
    PHP Version 7.1.28

    Plugin Contributor etoilewebdesign

    (@etoilewebdesign)

    Hi johnyyw,

    If you’re getting that error, it likely means that, in the “Basic” area of the “Options” tab, you either put nothing or a non-numeric value for the “Maximum Review Score” setting. Please have a look at that setting.

    Thread Starter johnyyw

    (@johnyyw)

    Hi! You mean “review options -> basic -> maximum review score” to leave blank / empty ? If I leave empty this error apears on all products

    Warning: A non-numeric value encountered in /home/…/public_html/wp-content/plugins/ultimate-reviews/Functions/EWD_URP_Replace_WooCommerce_Reviews.php on line 126

    if i set the value 5, this error apears to first product on shop pages..

    I had this same issue. Luckily our IT guy knows php and was able to hard code in php to hide the error message. The above recommended settings didn’t work for me either.

    Plugin Contributor etoilewebdesign

    (@etoilewebdesign)

    Hi @johnyyw,

    Could you make sure that you are entering numerical values for all ratings and that the maximum score is set properly?

    If that still doesn’t do it, please send us screenshots of all your settings.

    You could email us the screenshots at contact@etoilewebdesign.com
    if you’d like (just make sure to reference this thread when you do).

    djdubuque

    (@djdubuque)

    Issue popped up again. This time I’m not able to correct

    Warning: A non-numeric value encountered in /home2/xxxxxx/public_html/wp-content/plugins/ultimate-reviews/Shortcodes/SelectReview.php on line 361

    Warning: A non-numeric value encountered in /home2/xxxxxx/public_html/wp-content/plugins/ultimate-reviews/Shortcodes/SelectReview.php on line 362

    Again in the approved reviews it show the score as NAN and last time this happened I was able to set the score in the review now all that is in there is;

    Toggle panel: Review Details
    Reviewer’s Email:

    Email Confirmed: Yes No
    Product Name:

    Post Author:

    Review Category (if applicable)

    Plugin Contributor etoilewebdesign

    (@etoilewebdesign)

    Hi @djdubuque, we will continue discussing through email.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Warning: A non-numeric value encountered in’ is closed to new replies.