WordPress.org

Forums

[resolved] Want url to be "mysite.com" instead of "mysite.com/blog" - Suggestions? (5 posts)

  1. warrenleon
    Member
    Posted 9 years ago #

    Hi,

    Right now to get to my site, you have to go to mysite.com/blog, instead of simply mysite.com.

    Bluehost thinks that it's because I don't have an index.html file in my public_html folder, but didn't know how to fix it with WordPress.

    Someone helped me create an index.php that redirects people from mysite.com to mysite.com/blog, but I was wondering if there was a way to just have the blog be up on the regular url.

    Any thoughts? Thanks in advance for the help.
    WHL

  2. kaat
    Member
    Posted 9 years ago #

    Unless I'm mistaken, your whole wp install would need to be at that root level - not inside a folder called blog.

  3. Go to Options/General and change the two URLs there from http://mysite.com/blog to http://mysite.com . Then, move the contents of the /blog/ folder into your public_html folder.

  4. warrenleon
    Member
    Posted 9 years ago #

    Hi guys,

    Thanks, that worked! It's been a steep learning curve, with so much more to learn still, but at least my site's up (if empty). I'll fill it soon, but this is it so far: http://www.screenwritinglife.com.

    Thanks again,
    WHL

  5. oriecat
    Member
    Posted 9 years ago #

    Or if you still want the files in a folder, you can see here:
    http://wordpress.org/docs/installation/different-address/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags