WordPress.org

Support

Support » Plugins and Hacks » Want to update via GET request but sm_key is blank

Want to update via GET request but sm_key is blank

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same exact problem, any help?

    WordPress 3.4.2
    Nginx webserver

    Yeah, this is a real pain – I thought it was just me. I’ve done some poking around and it seems that the “secret key” isn’t being initialised when the plug-in is installed.

    I think you can force it to set it by clicking the “Reset Options” button at the bottom of the XML Sitemap Generator set-up page – but I’m too scared to try this as I spent ages tweaking at the other parameters and don’t want to lose them.

    So I edited the plug-in source instead (using FileZilla or the Plugins Editor option) to set an arbitrary key value of 12345678…

    File:     .../wp-content/plugins/google-sitemap-generator/sitemap-core.php
    Function: CheckForManualBuild()
    After:    $this->Initate();
    Insert:   $this->SetOption("b_manual_key","12345678");

    Then regenerate using:

    mysite.url/?sm_command=build&sm_key=12345678

    Works like a charm!
    Thanks pwr-uk.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Want to update via GET request but sm_key is blank’ is closed to new replies.