Support » Networking WordPress » Want to remove multisite, but no mention of it in wp-config.php and no #htaccess

  • This is a site I’m working on, but did not build. It is on a multisite network- but I would like to get it back to normal. There are no other sites on the network. All of the instructions tell me to remove lines from wp-config and edit htaccess, but I have no htaccess.

    Forgive me, but here is my entire wp-config file (with some edits in passwords, etc for security reasons):

    <?php
    /** Enable W3 Total Cache **/
    define('WP_CACHE', true); // Added by W3 Total Cache
    
    /**
     * The base configurations of the WordPress.
     *
     **************************************************************************
     * Do not try to create this file manually. Read the README.txt and run the
     * web installer.
     **************************************************************************
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'sad');
    
    /** MySQL database username */
    define('DB_USER', 'happy');
    
    /** MySQL database password */
    define('DB_PASSWORD', '!r00t!viv');
    
    /** MySQL hostname */
    define('DB_HOST', 'mysql.vivbizclub.dreamhosters.com');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt.*/
    define('DB_COLLATE', '');
    
    define('VHOST', 'no');
    $base = '/clientwpmu/';
    define('DOMAIN_CURRENT_SITE', 'vivbizclub.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169*/
    //define( "EDIT_ANY_USER", true );
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY', 'ca33a2de918a0af480015ae789d63b6d7b827e915d7a0f1b6d9421591d35b594');
    define('SECURE_AUTH_KEY', '5e26720be10870bf7fa47911a7df120c8251721c0a0e335ba9a93f366e3ea3b3');
    define('LOGGED_IN_KEY', '1864e9885fcab140334b07647ce62c469111278333f19b431a565f75aaa6b4f8');
    define('NONCE_KEY', 'e70a4ba95187cfa228d2370f787bba3c62d9d392c0973d79e769a5f64321eebc');
    define('AUTH_SALT', '9b69de5bc353d4448c59c6311d563b7e94405688ad3c975cf791419cd1106563');
    define('LOGGED_IN_SALT', '0ab2ac4972c3fb875c38f7193e3c394f94e1b1dbe334e04c6e268f777bb1bc43');
    define('SECURE_AUTH_SALT', '5e68a8f3f406a7ddf2d6c3fd660534815073aaa2fbbb15542f0dac14ab666eac');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    define( 'NONCE_SALT', '^/Rs9-(B^E-X,TwG<;H8h*Kh1HBUG5p~&|5j@/I]{9 c^h.;0MF9c#Z]hfBv}WY' );
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Thanks, but I can’t exactly tell which are the lines I should remove.

    I thought I should remove this section:

    define('VHOST', 'no');
    $base = '/clientwpmu/';
    define('DOMAIN_CURRENT_SITE', 'vivbizclub.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169
    //define( "EDIT_ANY_USER", true );*/
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );

    But then I end up with:
    “One or more database tables are unavailable. The database may need to be repaired.”

    Thank you SO much for your help-

    I tried removing the current wp-config.php and creating a new one through the WP setup process, but got database error then as well-

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    define('VHOST', 'no');
    $base = '/clientwpmu/';
    define('DOMAIN_CURRENT_SITE', 'vivbizclub.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );

    These.

    But keep in mind, you seem to be using an OLD version of Multisite (like WPMU 2.9 old)

    Yeah, tried that. Still get a database error. Uggh, guess I’m stuck with it? Any ideas?

    Thank you so much for your help-

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You may want to try rebuilding your config from the sample, just make a clean one.

    Yeah, tried that a couple of days ago 🙁

    Still get database error.

    Appreciate it though-

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    It’s probably all because you’ve got the ancient WPMU stuff in there… Bleah.

    Try adding this:

    define( 'WP_ALLOW_MULTISITE', false );
    define('MULTISITE', false);

    That didn’t work- but when I went into the database, I saw that it did have a prefix. I included that into wp-config and now I can remove the mu code and don’t get a database error!

    BUT I can’t log into the dashboard!! I know my user exists, I can see it in the database, but when I try to log in, no go and when I use the WP “recover password” feature, it says it doesn’t recognize my user or email address.

    Any ideas?

    So, fixed that, had to rename some database tables and include the prefix in the wp-config. Can load site, can log in.

    BUT images all broken. If you try view them by url, you get “Multisite support not enabled”. I never recreated .htaccess- is that the problem? I don’t see anything in that file referring o multisite, but-

    This is getting really old… I hope you have some ideas.

    Can’t add plugins either 🙁

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    That didn’t work- but when I went into the database, I saw that it did have a prefix. I included that into wp-config and now I can remove the mu code and don’t get a database error!

    What do you mean ‘a prefix’? You should have had wp_ or something. Was that what you mean?

    So, fixed that, had to rename some database tables and include the prefix in the wp-config. Can load site, can log in.

    What tables did you rename?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Want to remove multisite, but no mention of it in wp-config.php and no #htaccess’ is closed to new replies.