Support » Theme: Parament » Want to remove "Leave A Reply" from all pages

  • I am using this template for just a regular simple website. No Blogging and want No Comments left.

    How do I go about removing the “Leave A Reply” that is auto generated at the bottom of every page?

    I am about finished building this, which I have been doing on my personal PC and worried I made a mistake as all my links to photos and internal pages are “http://localhost/” Will they automatically change or will I have to redo all links, graphics and photo’s.

    Yes I am a 50+ old NEWBIE so be kind and I may need step by step help.

    Thanks so very much,
    Tim321

Viewing 6 replies - 1 through 6 (of 6 total)
  • OK I went into wp-content/themes/parament/page

    I then found the <?php comments_template(); ?>
    I changed it to <!– <?php comments_template(); ?–>
    This removed the “Leave A Comment” box as I wanted but made my right column move way down the page so I had to change it back.

    Any ideas out there? I don’t do coding or understand this stuff so am searching on-line and trying things out with an original backup incase I screw things up – which I have but have it all back to new again.

    HELP PLEASE

    OK again went into wp-content/themes/parament/page
    Found <?php comments_template(); ?>
    Switched it to <//?php comments_template(); ?>

    Seems to have worked like a charm.

    PLEASE let me know if this was a bad thing to do.

    Thanks,
    Tim321

    BTW I had added the Rich TextEditor and could not build files for images with it so I just explorer and made them since it was on my machine (localhost) and then input the path to it. Sure I did not do something I should have of did something I shouldn’t have to be able to make new folders.

    Anyway I am ready to upload this to my IP but am still concerned that all of my internal links and pathways to graphics etc. have been with paths starting with “http://localhost/”.

    Will I have to rework all links and graphic calls or will this somehow work when I upload this to my IP for publishing?

    Any help would be appreciated.

    Thanks again,
    Tim321

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Hi Tim321! To remove the comment form on every page you don’t need to edit the theme files at all.

    You can bulk-edit your pages and turn comments off that way, and the form won’t appear.

    Here’s a full guide on how to do that:
    https://en.support.wordpress.com/enable-disable-comments/#enabledisable-comments

    <//?php comments_template(); ?>

    PLEASE let me know if this was a bad thing to do.

    I’m afraid this was not a good thing to do, for a few reasons. 🙂 First, that is not valid PHP, so you may encounter unexpected errors. Second, you should not edit the theme files directly, or your changes will be overwritten and lost every time you update the theme to the latest version.

    The best way to make changes to a theme is to use a child theme, so your tweaks won’t be overwritten when updating the theme. Here are some guides in case you haven’t made one before:

    http://codex.wordpress.org/Child_Themes
    http://op111.net/53/
    http://vimeo.com/39023468

    If you go this route, you would simply remove this line from the page template file in your child theme, not modify it in any way:

    <?php comments_template(); ?>

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Anyway I am ready to upload this to my IP but am still concerned that all of my internal links and pathways to graphics etc. have been with paths starting with “http://localhost/”.

    Will I have to rework all links and graphic calls or will this somehow work when I upload this to my IP for publishing?

    See this Codex article: http://codex.wordpress.org/Moving_WordPress

    If you still need help moving your site from localhost to your live server, I’d suggest posting in the general how-to/troubleshooting forum. (This one is for help specific to Parament.)

    How-To and Troubleshooting

    Kathryn,
    Thank you so much for the reply.

    I changed the wp-content/themes/parament/page back to what it originally was and the Leave A Comment Box came back.

    Tried all the other things in the link and NO LUCK.

    I was told the <//?php comments_template(); ?> was indeed the right way to go and it did work, but you say bad idea.

    So I will now try to do the child Theme and remove the line as you advised.

    Hope it works. I will come back and let you know if it does.

    Thanks,
    Tim321

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Want to remove "Leave A Reply" from all pages’ is closed to new replies.