Support » Localhost Installs » WampServer really slow accessing pages in WordPress

  • Hi

    Recently I have noticed my WAMP SERver really slow when editing and adding pages etc. Mainly on my Woocommerce sites and sometimes just on normal sites as well.

    But it seems to be when my internet speed is really badly slow this gets worse affected.

    I thought the purpose of WAMP was that I could use it without internet and didnt
    realise that internet was causing it to be really slow, slower than usual.

    I have heard disabling cgi possibly might help, did this didn’t help.

    Surely I can use WAMPSERVER without internet so I can designing the WordPress website locally especially when I am somewhere with no internet I want to still be able to edit the site locally. Why then am I having issues when on internet ?

    Thanks
    Krsitin

Viewing 6 replies - 1 through 6 (of 6 total)
  • Having used WampServer in the past (I ditched it for Bitnami WordPress Stack: https://bitnami.com/stack/wordpress), I recommend checking if you have APC Installed/Enabled.

    There’s also another issue that I ran into that’s quite…simple. If you are on a local environment and your theme is referencing online assets like Google Fonts, Bootstrap CDN, etc, sometimes it makes a local site slow down because it’s trying to reach that particular resource on the internet and your connection might not be fast enough. If you are offline this could also cause slowness due to the site trying to reach the online assets anyway and getting “stuck” for a sec.

    HI

    Yes you have a point there, I actually tested that theory last night. Turned off internet entirely and worked OK but some areas until I needed the Ultimate shortcodes area.

    It seems to be related mainly with my Woocommerce sites I am using current latest version that I have worse thinking issues when processing and keeps saying “lost connection we are trying to backup your page” and will sit there for 1-2 minutes which is such a pain to wait especially when you have deadlines and lots to do.

    I sometimes will open another tab with the ADMIN and start adding another new page whilst the other tab is still thinking as it has been frustrating.

    My CPU is sitting at 70% wamp usage APache taking up resources when using Shopping site wordpress.

    Then tested it with another normal 3-4 page website non-cart and system resources CPU usage went down to 25%.

    Thanks
    Kristin

    Do you think there’s a chance you can try Bitnami to also rule out a WampServer-specific issue?

    Another one you may consider is Laragon. It is the fastest local server that I have ever used, and I have used pretty much all of them, including Bitnami (which is basically XAMPP) 🙂

    Cheers!
    Lyle

    Yes thanks for both of those options .. I will have to try another workaround definately I think.

    I have been using WampServer for many years now with not any issues.

    Can I still have WAMP installed when I install these other 2 so I can test them out ? They will not interfere with each other ?

    Thanks
    Kristin

    HI, Do you think if I do it now in the middle of a project hopefully it doesn’t affect my site starting with new software. I would need to ensure I have same SQL and PHP versions obviously also won’t I ?

    Thanks
    Krsitin

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WampServer really slow accessing pages in WordPress’ is closed to new replies.