Support » Localhost Installs » Wamp WP3.5

  • I upgraded my localhost environment with the 3.5 and lost all my admin privileges. So I tried to manually add them straight into the database with phpmyadmin but no luck. From reading the forums about conflicts with plugins I did a complete reinstall of Wamp and a fresh wordpress installation with the default themes and no added plugins via me.

    The installation I think is failing after I fill in my site title, name and password and hangs without completing. Refreshing the page will bring up a login that my password/name isn’t recognised so I go back to the database and add myself there(followed this tutoiral )

    I can publish a page but have no access to installing themes,plugins or menus and widgets. Is there a way to add these via the database tables? Bright side? My live site upgraded without a hitch.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Not sure if you’ve solved this, as it’s a few days old, but just in case and as a temporary workaround …

    I’m having problems getting back into the WP dashboard on a local WAMP server too.

    I’ve found that if I delete the wp-config.php file (or rename it actually, just in case) it forces the system to recreate a wp-config.php file, then says ‘OK go ahead and install WordPress’ … then says ‘oh, you already have’ … then presents me with a sign-on screen that let’s me in to the dashboard to do whatever I like.

    Downside is it only works for that session, so you have to repeat if you come out of the admin side of WP then want to go back in later, but it MIGHT work for you as temporary / emergency access? (I’ll keep hunting for a ‘permanent’ solution!)

    Thanks Michael but still no luck on my end. I’m having a discussion over on the Wamp Forums and so far what I’ve done is correct. If you do find a solution please let me know.

    Most certainly will, drec. Likewise if / when you do, post it up here in case it works for me too!

    At the moment I’m recreating the wp-config file whenever I need to work on a website, then just leaving the browser open so I remain logged in as long as possible. Not ideal, but at least it works!

    Michael, I’ve given up on wamp and tried ServerPress and everything has installed effortlessly. Could be worth a look if your problems aren’t sorted.

    Thanks for the update drec.

    My ‘login’ problems seem to have solved themselves (magically, I guess, cos I’m not aware of doing anything to fix it!)

    Weird quirks like not accepting a leading “/” in image and file paths, and for some reason doesn’t like anything but “default” permalinks. Not a big problem right now, but might be when I’m working on some other sites.

    So I’ll stick with Wampserver for now, as I’ve invested quite a bit of time in setting it up, but if the permalink thing becomes an issue, I’ll give ServerPress a try. 😉

    Tip for others who come looking at this thread:

    Might be worth STARTING with ServerPress! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Wamp WP3.5’ is closed to new replies.