Support » Plugin: WooCommerce » Wamp, WordPress, Woo Commerce error

  • Installed the latest version of Wamp locally on a Windows XP machine, downloaded and installed the latest version of WordPress, which went fine. Downloaded and attempted to install the latest version of Woo Commerce locally to test functionality and received the following error when trying to activate the Woo Commerve plugin:

    Fatal error: Class ‘WC_API’ not found in C:\Documents and Settings\Mike\My Documents\wamp\www\elegance\wp-content\plugins\woocommerce\woocommerce.php on line 142

    I edited the php.ini file changing the following from 2M to 100M
    post_max_size= 100M
    upload_max_filesize= 100M

    rebooted the system after saving the files, and tried to activate the Woo Commerce plugin and received the same error.

    I am not well versed in PHP and am assuming it is a possible issue with WAMP/php settings. Any guidance would be greatly appreciated. I apologize if I have omitted any necessary data.

    Thank you.

Viewing 1 replies (of 1 total)
  • I too need assistance with this. But the error started showing up on my live production site, shortly after I tried to make a local copy of my wordpress site for development.

    Note: It happens the first time you hit the page, then if u refresh it goes away?

Viewing 1 replies (of 1 total)
  • The topic ‘Wamp, WordPress, Woo Commerce error’ is closed to new replies.