Support » Plugin: Bitcoin and Altcoin Wallets » Wallet not showing

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    Not sure why this happened.

    First, try to deactivate and re-activate the plugin.

    If that doesn’t work, use another plugin to edit the capabilities of the admin user. The admin user should have the manage_wallets capability for the menu to show.

    You can use User Role Editor for this. Go to “Users” -> “User Role Editor” -> select “Administrator” -> “add capability” -> manage_wallets. The capability must be checked. Click “update”.

    This should resolve the issue. Let me know if it doesn’t.

    with regards,
    Alex

    Thread Starter Henry Okonkwo

    (@mdomain20)

    Thanks for your swift response.. According to your instructions,
    I did check -> “User Role Editor” -> select “Administrator” -> “add capability” ->, but couldn’t find manage_wallets on the list.
    This are screenshots.
    Screenshot 1, screenshot 2, screenshot 3,

    This is strange than usual because the plugin is quite activate,
    This are what have tried:
    • Deactivation of All Plugin and Reactivation.
    • Deactivation of Theme and Reactivation with default.
    • htaccess is okay
    • Uninstall of Bitcoin and Altcoin Wallets and reinstall.

    Nothing is forthcoming..
    I need your assistance as this project is for my client.

    Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    If the manage_wallets capability is not there, you need to add it by typing it. Then ensure it’s checked.

    Then the menu will be shown.

    Once the menu is shown, you should go to Wallets -> Capabilities and check all the other capabilities as well. The roles for users should typically have all the shown capabilities besides manage_wallets which is for admins.

    with regards

    Thread Starter Henry Okonkwo

    (@mdomain20)

    Thanks for your time and help.. thank fixed the issue.. but it’s also showing this error message.

    ‘The wp_cron tasks have not run in the past 4 hours.You must either enable auto-triggering or trigger cron manually via curl/system-cron.”

    Please, How do i auto trigger this or how do i fix it… ?
    And is this triggering recommended?

    Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    If you saw this message once, then it’s because your site is not yet receiving traffic. By default, crons can only be trigerred when you or someone else is visiting the site.

    If you continue to see the error message, please open a new thread on this forum, and we’ll explore this.

    with regards

    Thread Starter Henry Okonkwo

    (@mdomain20)

    Thanks.. your help solved the case…

    Thread Starter Henry Okonkwo

    (@mdomain20)

    Bitcoin and Altcoin Wallets error
    The Bitcoin RPC API cannot be contacted.

    First check that your Bitcoin RPC connection settings are correct.
    Then edit your .conf file and append the following:
    ——
    1. How do i achieve editing .conf from my cPanel, file manager..?
    2. I can’t find .conf within the plugin files understand cPanel file manager?
    ——
    I have seen the tutorial, I don’t seems to understand it from part 4…

    Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    It is not possible to install Bitcoin core wallet via cPanel. You must have some expertise with Linux administration and the shell to install and maintain the wallet.

    If you are not familiar with system administration, you could consider using the plugin with the CoinPayments adapter.

    If you want to use the plugin with a full node, install the Bitcoin core client on a server with sufficient resources. You will find the conf file in ~/.bitcoin/bitcoin.conf.

    with regards,
    Alex

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Wallet not showing’ is closed to new replies.