Support » Plugin: Sucuri Security - Auditing, Malware Scanner and Security Hardening » Waiting for Sucuri Security 1.8.11 to be tested with WordPress 4.8.1

  • Resolved deeveedee

    (@deeveedee)


    WordPress 4.8.1 reports that “Warning: This plugin has not been tested with your current version of WordPress.” for Sucuri 1.8.11.

    Please let us know when Sucuri Security plugin is tested with the latest version of WordPress.

    Thanks for a great plugin and for all your hard work!!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have not updated to this newest Sucuri plugin version either waiting for it to be tested with the current WP version.

    Please let us know when that has been done. Thank you.

    Can the plugin author please update us on when the newest version of the Sucuri plugin will become compatible with WordPress 4.8.1? As the others have already said, as it currently stands, it is only compatible up to WordPress 4.8.0. I have been waiting for a few days now and the issue still persist. Thanks.

    Can the plugin author please reply to give us an idea of when the updated version of the Sucuri plugin will be tested with the latest version of WordPress? It has been nearly a week since the plugin update & we’re still seeing the compatibility warning.

    As far as I understand WordPress follows SEMVER [1]:

    Given a version number MAJOR.MINOR.PATCH, increment the:

    • MAJOR version when you make incompatible API changes,
    • MINOR version when you add functionality in a backwards-compatible manner, and PATCH version when you make backwards-compatible bug fixes.
    • Additional labels for pre-release and build metadata are available as extensions to the MAJOR.MINOR.PATCH format.

    If WordPress is doing this correctly, any change in their code under the PATCH must follow the same API as the other patches, so if we [Sucuri] tested the plugin against WP4.8.0 it should work the same way for WP4.8.N where N is any positive number.

    However, just to confirm, I tested the plugin today against WP4.8.1 and again with WP4.9 and everything works as expected. I actually run the automated tests for the entire codebase every day as part of our continuous delivery process [2].

    Thank you for the interest; marking as resolved.

    [1] https://semver.org/
    [2] https://en.wikipedia.org/wiki/Continuous_delivery

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Waiting for Sucuri Security 1.8.11 to be tested with WordPress 4.8.1’ is closed to new replies.