Support » Plugins » W3TC Plugin Conflict

  • fredrick,

    Hi, I’m the developer of another plugin called Pretty Link. Several of my users have reported that they are having problems saving their Pretty Link settings when W3TC is installed and active.

    I have narrowed this down to some kind of conflict with W3TC Object caching. I’m storing options in a serialized object which is retrieved from the database like so:

    $prli_options = get_option('prli_options');

    Then I modify the object and update it like so:


    Getting the object seems to work just fine but then when I modify the object and attempt to update it using update_option with object caching the new object is not inserted into the database.

    I have tried modifying my code to use wp_cache_get/set, have attempted to flush the w3tc object cache before calling update_option and have even setup a caching group & tried adding it to the non-persisting list in w3tc — all of these approaches have failed.

    I’d really love it if there was a way that I could update this and other objects I’m serializing and storing in the database. I’ve googled this issue (which I know is affecting other plugin developers) and haven’t seen any answers to it.

    I really appreciate any insight you might have.



Viewing 8 replies - 1 through 8 (of 8 total)
  • I just tried adding this:

    define('DONOTCACHEOBJECT', true);

    It still won’t update the object in the database.



    Can you submit a bug submission form from the support tab of the plugin? I’d like you to try the next release that I think addresses this.

    Sure — doing it now … thanks!


    Thanks a lot, this is addressed already in the upcoming release. Can send you a preview if you like.

    Fantastic — I’d love to see a preview … you can just email it to me if you want. Thanks for your response on this — you and your team are great!

    @ Frederick

    Any chance of releasing the upcoming release under the DEV version for wide testing? I am having issues listed in other threads, and would love to test it.

    Compatibility is working in the next release coming soon.

    Any update on a workaround for this?

    I have a separate plugin that tweets out a blog post then updates a field in the DB. I know it works find for everyone who is NOT using W3TC as they don’t have object caching in place.

    But it looks like if you do, the field is never updated in the DB and causes a big error with the plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘W3TC Plugin Conflict’ is closed to new replies.