WordPress.org

Support

Support » Plugins and Hacks » W3TC not reflecting CSS changes?

W3TC not reflecting CSS changes?

  • I recently updated my CSS file and went through the process of pushing the changes to Amazon’s cloudfront. I checked my bucket there and the CSS file on the site is one with the changes. I also can see the changes on my iPhone if I don’t use WPTouch (iPhone is in the rejected user agents in the W3TC settings so it’s not getting the cached version of it).

    I’ve tried flushing the page cache multiple times and I’ve even used a variety of browsers (ones that have never visited my site) to be sure that Safari isn’t holding on to the cached version of the file. The CSS changes were to my archive pages – you can see it at http://www.durhamdbt.com/blog/2010/10/ . The element h2.entry-title should no longer be “display: none”. Thoughts?

    Update (before I even post this): Turning off the gzip compression in the Browser settings fixes the problem. I did some digging and the .gzip CSS file on Cloudfront isn’t updated. Where do I re-gzip the file and update it?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have had a similar issue with a background image returning randomly on Internet Explorer.

    I have cleared the cache multiple times on both the browser and the plugin. I have deleted files in the CDN bucket. But as soon as I think it’s gone a page is served from the plugin and the background is there again

    I solved my issue… I use GoDaddy shared hosting and they had given me a code to add to my header.php for gzipping:

    <? ob_start("ob_gzhandler"); ?>

    It just dawned on me that that may have been causing all of my CDN issues and having removed that, I may be right.

    That actually is not the solution to your problem, it should actually break W3TC to be honest. Anyway, anyone having this issue can feel free to submit a bug submission form from the support tab of the plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘W3TC not reflecting CSS changes?’ is closed to new replies.