Support » Plugin: W3 Total Cache » w3tc and Newspaper theme issue

  • Resolved skredlemon

    (@skredlemon)


    I am using W3TC together with the Tag Div Newspaper theme. I started with the Page cache enabled, but then I noticed a couple of cases where that was causing me trouble with the way some pages were cached and loaded. In specific, the home page would load as if it was a mobile device when it was a desktop one, or vise versa.

    Similarly, for templates where there were no horizontal or vertical tablet settings set, and no mobile settings set either, but separate mobile templates existed for those cases, the cache would load the versions based on the desktop site. As a result no content was loaded for single posts, except for a couple of ads banners.

    To make these unwanted effects disappear, I was forced to disable the page cahce, but now I am experiencing a speed decrease of as much as a couple of seconds per page load. Effectively, page cache does not work for any of the pages.

    I was hoping perhaps you would have some suggestions on how to best configure W3TC to make my pages load as fast as they could, without any such unpredictable side effects.

Viewing 1 replies (of 1 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @skredlemon

    Thank you for reaching out and I am happy to assist you with this problem.
    You can use User Agent Groups for this in Performance>Cache Groups> Manage User Agent Groups.
    Follow the instructions on that page. There you can create a group of user agents by specifying names in the user agents field. Assign a set of user agents to use a specific theme, redirect them to another domain, or if an existing mobile plugin is active, create user agent groups to ensure that a unique cache is created for each user agent group. Drag and drop groups into order (if needed) to determine their priority (top -> down).
    Drom what you are saying the problem is, you should enable both “high” and “low” groups, and select your theme in both groups dropdown menu under Theme:
    Make sure to save all settings and purge the cache.

    After you enabled the User Agent Groups, go to Performance>General settings, enable Page Caching, save all settings and purge the cache.

    Let me know if this helps!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.