Support » Plugin: W3 Total Cache » W3TC Killed My Backend

  • Resolved billrose


    I just updated to WordPress 3.5.1 and W3TC at the same time. Site is still live, but my backend is dead – it gives me the white screen with the error message below. I tried adding a blank ‘master.php’ file to /wp-content/w3tc-config without any success.

    Fatal error: Uncaught exception 'FileOperationException' with message '<strong>/home/recaptur/public_html/wp-content/w3tc-config/master.php</strong> could not be created, please run following command:<br /><ul><li><strong style="color: #f00;">chmod 777 /home/recaptur/public_html/wp-content/cache/tmp</strong></li><li><strong style="color: #f00;">chmod 777 /home/recaptur/public_html/wp-content/w3tc-config</strong></li>' in /home/recaptur/public_html/wp-content/plugins/w3-total-cache/inc/functions/activation.php:127 Stack trace: #0 /home/recaptur/public_html/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error('/home/recaptur/...', Array) #1 /home/recaptur/public_html/wp-content/plugins/w3-total-cache/lib/W3/Config.php(71): W3_ConfigWriter->save() #2 /home/recaptur/public_html/wp-content/plugins/w3-total-cache/lib/W3/CloudFlare.php(174): W3_Config->save() #3 /home/recaptur/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/CloudFlare.php(52): W3_CloudFlare->update_ip_ranges() #4 /h in /home/recaptur/public_html/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 127

    Can someone please walk me through how to fix this?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Comment out this “/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 127”

    You dashboard will be accessible. Then deactivate the plugin, activate again, and configure if needed.

    Thanks for that tip… solved the problem for me…

    Just to be clear:
    1. Comment out line 127 in activation.php
    2. Your dashboard comes back – deactivate W3TC
    3. Remove the comments for line 127 so it is active again
    4. Activate W3TC and you are back in business

    @m Asif Rahman – Thank you, that solved it for me.

    @andersvinther2 – Appreciate you detailing the steps. I needed that!

    Hello there,
    Can you
    help I tried to install wp e-commerce plugin and I keep getting this message
    Fatal error: Cannot redeclare my_action_row() in /home/proixclj/public_html/ on line 452
    when I try to get to my site?
    Can you help please?

    Wow! This worked! Thank you!

    For those even “newbier” code people (like me) use the symbols below to comment out the line 127 using a code editor through your Cpanel or FTP access. (Only use symbols within the brackets. Don’t include the brackets.)

    At beginning of line 127 type: [/**]
    Create a blank line 128 and type into it: [*/]

    Your commented out line 127 code should look thus:
    /** throw new FileOperationException($error, ‘read’, ‘file’, $path);

    Save file and complete Step 2 from list above.

    To reactivate, remove the /** and the blank line with */ and resave the file again.

    You should be back in business.

    Specifics of what I did: Upon updating my WP site to 3.5.1 along with a slew of other Plugins including the WT3 update, could no longer access my Dashboard or other backend pages. My site was live, but blank admin and login pages. Did the 1,2,3,4 list above and now it’s fixed and working!

    I followed the instructions given and the backend continues to have the Fatal Error.

    Any ideas?

    Thanks in advance,
    J. Barry

    This happens because updating W3TC does a pretty inconvenient thing which should probably regarded as a bug. Once I updated w3tc it completely eliminated all settings that were there before (Performance->General Settings).

    It also reverts to disk-basic for all caching which means it wants some directories that probably aren’t there in your install, e.g. wp-content/cache and wp-content/w3tc-config which you can fix for example by doing commands like so *before* updating w3tc :

    mkdir -p /home/ && chown -R nginx.nginx /home/ && mkdir -p /home/ && chown -R nginx.nginx /home/

    Obviously replacing /home/ with the correct path for your website’s root html directory and nginx.nginx with the use the webserver is running as.

    Once you’ve done this you can do the update without getting a text editor involved and going through manual deactivate/reactivate.

    If you’ve already done the original instructions above, you probably want to verify your performance->general settings didn’t get blown away by it, and if you’re still having the errors maybe try that command to see if it fixes it.

    I was wondering if I could just blow away the w3tc directory and subs and reinstalling?

    J. Barry

    FWIW, I was seeing the same error activating the plugin. Commenting out activation.php:127 allowed for activation and /w3tc-config and /cache still got created in wp-content. I uncommented that line and things are working fine.

    Thank you!!!
    billrose, andersvinther2, VivaWP, afk4life and Jon Brown!

    It worked! It’s back! I’m wicked thrilled! You guys/girls are the best!

    Drinks on me 🙂
    J. Barry

    i have the same problem.

    I tried to comement off line 127 but my activation.php file has only 87 lines. I have downloaded the last version of W3 TOTAL CACHE ( and upload activation.php over the existing file, then i have comment off line 127, then save and still not works.

    What can i do in this case? How can I solve this problem? What should I delete from the remote to get rid of this problem.

    I mention that I do not want to keep W3 Total Cache

    Can someone please help me?


    I got same error and applied the changes suggested by @andersvinther2. it works for me.


    Please send us a note if you’re still having issues with

    Hi Willie,

    Is there a new version on the way which solves this problem?

    I have held off updating a number of my sites partly because of the manual intervention required to upgrade successfully partly because I was hoping for a quick release of a version which fixes this problem and didn’t want to update all my sites twice…

    However if you’re not planning a new release any time soon I’ll continue with the rest of my sites…

    Thanks 🙂

    I got the same error when I tried to update the plugin from the WP autoupdate on the plugins page.
    Thank you @m Asif Rahman! I found your blog page at and followed all the steps.

    Fortunately I had done other plugin updates before getting to this one so I had cleared the cash already and the autoupdate had already deactivated W3TC. Commenting out line 127 in activation.php let the plugin be activated. After activating it, I then uncommented line 127 in activation.php and the /cache got created in wp-content. Everything seems fine now. Such an easy fix for such a scary error message!

    I am surprised it has been a month since this was released and a fix in the plugin hasn’t been done.

    These two discussions back this process up:

    I also found that if you want to uninstall W3TC, you have to jump through hoops: (3rd entry)

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘W3TC Killed My Backend’ is closed to new replies.