Support » Plugin: W3 Total Cache » W3 won't save cache method

  • I’ve tried sending support requests via W3 backend as a Pro Customer, but have had no response.

    Whenever I try to chance from disk caching to say Memcached or APC it won’t save on the admin end.

    It always says disk. When I click into the General Settings section and let it load up and then click away to another page, it asks me am I sure I wish to change (like as if I’ve made a change and forgotten to save it) despite not having touched a thing.

    I find that in the source code, that the last item I have saved to be memcached or APC will actually be using that method but I cannot change another other service.
    So if I set Object cache to Memcached. Save and load a page. It says object cache is using memcache.
    If I then set database cache to Memcached. It now says Object cache is using disk and DB cache is using memcache.

    Latest WordPress. Latest W3 Total Cache. Nginx + PHP-FPM.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi Dionis,

    what does it say in the install tab under W3 Total Cache. Is htaccess and wp-config writable? The rewrite rules must be in the three htaccess files stated on the install tab in order for it to work properly.

    Hope that helps

    Sorry I ment wp-content directory, not wp-config…

    Yes of course. It’s a long standing wordpress install. This is a recent development to a normally working W3 Total Cache.

    WordPress Resources

    nginx.conf: OK
    wp-content: OK
    wp-content/uploads/2014/03: OK
    Fancy permalinks: /%postname%/
    WP_CACHE define: Defined (true)
    URL rewrite: Enabled
    Network mode: No

    Plugin Version: 0.9.3
    PHP Version: 5.4.26;
    Web Server: nginx
    FTP functions: Installed
    Multibyte String support: Installed
    cURL extension: Installed
    zlib extension: Installed
    Opcode cache: Installed (APC)
    Memcache extension: Installed
    HTML Tidy extension: Installed (required for HTML Tidy minifier suppport)
    Mime type detection: Installed
    Hash function: Installed (hash)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    set_time_limit: Available


    No the install tab under Performance (w3), in the WordPress admin back end. It should look like this:

    Rewrite rules


    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            BrowserMatch ^Mozilla/4 gzip-only-text/html
            BrowserMatch ^Mozilla/4\.0[678] no-gzip
            BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
            BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>

    It’s Nginx not apache

    There is no .htaccess it’s nginx.conf
    As per last post, nginx.conf is writeable and the install page isn’t the page that confirms it is writable, it’s the compatibility page.


    Sorry but I am unfamiliar with nginx… I do not know how W3 works under those conditions.

    It’s pretty much the same, just a different web server and the rules saved to a different configuration file.

    It’s a previously working system. It just seems to be broken right now and I don’t know why.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘W3 won't save cache method’ is closed to new replies.