WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache yielding 404 pages

W3 Total Cache yielding 404 pages

  • Hey all,

    Background information on my bug:

    • My W3 Total Cache (W3TC) settings dictate that non-logged-in users always see a cached version of a post.
    • My site has about 20 new posts a day

    Occasionally, non-logged-in users will see a 404 page for a particular post. To resolve the issue, I simply have to activate the ‘flush cache’ feature in the W3TC admin area.

    Is there a reason why some posts display a 404 page to non-logged-in users? Anyone else experience this?

    W3TC is the best plugin I have used for WordPress.

    Thanks,

    Kevin

Viewing 15 replies - 1 through 15 (of 23 total)
  • What is your page caching method? Can you duplicate this issue at will?

    I see this old thread kinda died, but I have the same issue. As far as I can tell, it’s only on one page on my site. The page works when I log-in, but it shows 404 not found when I’m not logged-in. If I purge the cache for that page and tell W3TC not to cache that page, it works fine. But if I remove this page from the “never cache” list, it shows up as 404 to visitors again.

    Any ideas?

    Any suggestions on this?

    The same problem here.

    It ended with me deleting the plugin then reinstalling it, and I turned of the minification since I thought that was the issue, but random pages end up cached as 404 and have to purge them from cache (most often the RobAid Archives page which is the largest and “heaviest” page on site).

    Settings:
    – disk: enhanced caching with prime caching (which causes the Archives page to become a 404 page after it is rebuilt)
    – minify is off (most of the website assets are minified manually, and HTML is minified via CloudFlare)
    – DB and object cache are on default values and use APC

    Update: Tried to turn off DB and object cache but random pages still end up as soft 404.

    jillsays

    @jillsays

    Add me to the list of people having this problem. I’m using the newest versions of WordPress and W3.

    Random pages on the site are returning 404 errors and not loading. All the content loads on the site (header, sidebar, footer) – but the actual content just returns a 404.

    When I clear the cache, the pages return – temporarily, and then it happens again.

    I turned off browser caching and minify, but the problem persists.

    Can anyone weigh in on what might be causing this?

    Mike

    @maddogmike

    Just found another page yielding 404 again. Submitted a ticket though the W3TC admin panel. Will report back when I get an answer.

    I’m really not sure, but could this occur if search engine bot is indexing a page before anyone has visited it and forced cache?

    Turned off prime caching and the problem occurs less often but it\s still there 🙁

    That shouldn’t matter. If a visitor, bot or not, visits a page before it is cached, it should just serve up the page from the database. After that first visit, a cached version should be served. In no case should a 404 be served as long as that page still exist. No word from the author yet … I’m sure he’s busy, hope to hear soon.

    I think I did something bad when I uploaded my media files again. There was a checkbox that said something about adding a 301 redirect in the .htaccess

    I deactivated w3 Total Cache, then went into .htaccess and deleted the section for w3total cache and my 404 errors went away.

    Hope this helps. Please backup and modify the .htaccess lightly because you can really mess up your site.

    Aloha,
    arlen
    hawaiiwp.com

    Hmmm, I’m not following where this checkbox was that you checked. Anyway, I don’t see anything abnormal in my .htaccess. The only reference to 301 redirects on my .htaccess are the standard non-www to www redirect, and the one for Cloudflare.

    The only reference to 404 in my .htaccess is the “Skip 404 error handling by WordPress for static files” language. That should be related to the W3TC setting to “Cache 404 (not found) pages.” I thought about deselecting that choice, but all that does is cache a page that’s already a 404. A page that’s still live in the database shouldn’t be presenting a 404 to begin with.

    OK, I just found that my effing home page was showing 404. Purged the cache and now it’s back. Seriously, what is the deal here? Multiple posts and tickets submitted and no response.

    Since this is a random issue, it’s quite hard to duplicate and debug. If anyone has specific steps to duplicate or some errors form an error log to report, that would be much appreciated.

    I can’t seem to find any specific steps to reproduce, it just seems to be random pages showing 404. I will say that I cleared the checkbox on the W3TC setting to “Cache 404 (not found) pages,” and I have not see the problem since.

    Thanks helpful. Can you submit a bug submission form from the support tab of the plugin referencing this topic so I can investigate further?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘W3 Total Cache yielding 404 pages’ is closed to new replies.
Skip to toolbar