WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache throwing weird errors

W3 Total Cache throwing weird errors

  • So I try to install W3TC and I get these errors:

    “It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.”

    and


    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.”

    Naturally, I double triple quadruple check the sever, no issues. I AM using .htacces indeed. So I check the compatibility check and it’s full of “false postivies”:
    mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)

    The server DOES have these modules. So I am not sure what is going on here.

    Ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Your server may be using fast cgi or similar, so the plugin can’t detect the modules. Which web server are you using?

    Hello Frederick,

    No FCGI, just Apache 2.22 + PHP 5.3.10 and suEXEC with suhosin and mod_security. The funny thing that I have dedicated servers using that setup, but the issue only appeared on the VPS, which is very interesting really.

    What do you think?

    I’m in a similar boat. Ditto for the errors, running VPS. Two sites have these issues, different VPSs.

    @michael Cannon

    KVM based VPS by any chance?

    @ahmed,

    No. I’ve decided to turn off suphp and suexec and try recompiling the latest PHP/Apache for my ServInt VPS with cpanel.

    I’ll see if things change shortly. I’m still trying to debug if it’s permissions conflict because of the cgi or dso PHP instances.

    Ciao!

    @michael Cannon any update?

    @frederick, the recompile helped with the esoteric minification not working errors, but the feeds were fixed once I turned off caching for them. Sorry, no real information on how to reproduce the problem or the fix.

    Do folks here want to submit a bug submission form from the support tab of the plugin for better help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘W3 Total Cache throwing weird errors’ is closed to new replies.
Skip to toolbar